0

When i try to load any web oage (askubuntu.com for example), noscript addon blocks some scripts from a domain called best-deals-products.com I've searched about this topic on duckduckgo and google and result goes to lenovo and windows related products while i'm using kubuntu on my desktop computer which is not made by lenovo.

  • Does this happens starting Firefox in safe mode? What addons do you have installed in Firefox? – xangua Jun 19 '15 at 16:05
  • Burn your Firefox profile, and remove addons. Then install NoScript, and try again and see this happens. If not, then something in your profile (addons, etc.) was involved. (NOTE: Burning your firefox profile will remove all your configurations, cookies, favorites, etc.) – Thomas Ward Jun 19 '15 at 16:06
  • @xangua Thanke you so much. the problem was because one of my addons called "youtube video downloader" after removing that one, my browser is working like a charm with no unwanted script. how can i mark this question as solved? – Mansoor Jun 19 '15 at 16:37
  • @the_Seppi done, and expanded – Thomas Ward Jun 19 '15 at 17:18
  • @Mansoor you can now click the green ✓to the left of the answer below to accept it and mark this question as solved. – s3lph Jun 19 '15 at 22:22
1

The problem is a plugin in Firefox somewhere is doing this. We have to identify and remove that plugin. There's two ways to go about that.


The destructive method:

This is essentially trying to kill a fly with a huge weapon instead of a fly swatter.

Burn (aka delete and reset) your Firefox profile, and remove all addons. Then install NoScript, and try again and see this happens. If not, then something in your profile (addons, etc.) was involved. (WARNING NOTE: Burning your firefox profile will remove all your configurations, cookies, favorites, addons, etc.)


The not-so-destructive method:

This is systematic identification and removal of the plugin causing issues.

Alternatively, a less destructive option is to disable your addons one at a time until you find the addon that is doing this, then disable/remove that addon. This will save your favorites and such.

1

The culprit is "1-Click YouTube Video Downloader" Firefox Addon. When I disabled it, firefox no longer visits www.best-deals-products.com automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.