9

In IRSSI, I've always been able to use alt3 or alt5 to jump directly to specific windows. That seems to have stopped working. I think it probably happened with the update to 15.04, but I can't swear to that.

I can still use alt-> or ctrln to cycle through windows but I don't see a way to hop right to the window I want anymore. So ... how do I get that functionality back? Or is there a new way I can hop straight to a specific window in irssi?

  • This question should be moved to unix.stackexchange.com, it's definitely not Ubuntu Linux specific (not even Linux specific). – pevik Apr 25 '18 at 13:37
9

Finally worked this out. The alt+number conflicts with gnome-terminal's keyboard shortcuts to switch between tabs. That was always the case, but in older versions of gnome-terminal the combo would switch tabs if there were tabs to switch to and switch IRSSI windows if there weren't.

If you disable or re-map the "Switch to Tab ..." shortcuts (at Terminal > Preferences > Shortcuts) you can use alt2 in IRSSI again.

Double-click on the shortcut key and you'll see "New accelerator..." -- from there Backspace will disable the shortcut, or you can create a new shortcut. I used ctrlalt2.

| improve this answer | |
  • 6
    Escape also works as Alt key. So you can use Esc+2 to move to window numbered 2. – cnvzmxcvmcx Dec 26 '15 at 13:12
  • this also happens to me in freebsd in vbox. – Andrew Nov 27 '19 at 0:28
3

You can also use the commands /1, /2, ... /N, which is what I like to do.

| improve this answer | |
0

Click on Terminal icon > Preferences > Shortcuts

Then, uncheck Enable Shortcuts

Alt + 1 for example will work now. The problem for the terminal window is that the alt keys are mapped to switching to the terminal tabs (if you use those).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.