1

I have a slightly irritating issue that I haven't found an answer for on the Internet.

I have a laptop running Ubuntu GNOME 15.04 with an integrated Intel graphics card, a discrete Nvidia graphics card, and I've connected a Samsung monitor to use as a second display using the HDMI port.

The setup works fine and does exactly what I want it to, for the most part. The laptop serves as the primary display, the Samsung monitor serves as the secondary display.

But when I resume my computer after it has been suspended, the Samsung monitor comes to life first as the primary display and the laptop display is turned off.

The fix is easy. If I open gnome-control-center display, make any change, and then click Revert Settings, my original setup is applied.

I'd like to find the problem and fix it or, failing that, write a script to more or less automate the Revert Settings process after resume so that I don't have to do this manually every time I open my laptop.

Any advice?

edit: Another bit of information

xrandr results when displays are working properly

Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
HDMI-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm

xrandr results when displays are not working properly

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
eDP1 connected primary (normal left inverted right x axis y axis)
1

Do you use the nvidia proprietary drivers or the nouveau open drivers? (If you don't know run lsmod | grep nouveau if it gives you any results, it's nouveau; if lsmod | grep nvidia gives you any results, it's the proprietary nvidia drivers). If you have the nvidia drivers you should be able to configure the monitors from the nvidia-settings utility that comes with the drivers. Or you could try xrandr --output DVI-I-0 --auto --primary --left-of DVI-I-1 as superuser, where DVI-I-0 is the name of the monitor (should work regardless of drivers)

1
0

I've had a similar problem. My fix was via gui. I had automagically supplied on my install iso. Try graphics driver fglrx. This worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.