I get sound just fine using Chrome (e.g. YouTube) or with Rhythmbox playing an MP3.

However, VLC, Xine, and the default Ubuntu "Videos" make no sound, whether with MP4, FLV, or MP3. How do I fix this?

Ubuntu 14.10 Lenono M30-70

  • Make sure you have the right output selected in System Settings > Sound > input – spacelander Jun 19 '15 at 15:08
  • The app-specific volume for VLC is at max,yet there is no sound. – Joshua Fox Jun 20 '15 at 17:59
  • did you install ubuntu-restricted-extras ? – JoKeR Jun 25 '15 at 14:14
  • Apparently that was not the issue. When I gave the command to install ubuntu-restricted-extras, I got "ubuntu-restricted-extras is already the newest version." – Joshua Fox Jun 25 '15 at 19:19
  • did you try to switch/change audio outputs in vlc preferences? By default it's automatic try manually to switch it to alsa and then pulse etc... – JoKeR Jun 26 '15 at 6:46

15 Answers 15


In VLC, in Audio settings, I chose Reverse Stereo, and suddenly I got sound back!

Following that: Left, Right, and even regular Stereo now work.

  • 3
    Wow, weird. Congratulations on the fix. I'm not sure why it works, but I'm glad it does. – Tamsyn Michael Jun 28 '15 at 15:33
  • Nice, but realy strange – Otto Nov 29 '16 at 16:43
  • Where specifically in audio settngs did you find Reverse Stereo? @Joshua Fox – fixit7 Jun 23 '20 at 14:07

On VLC > Right Click > Audio > Audio Devices > I had 2 devices HDMI Audio and Built in Analog Audio. Selected one was the HDMI Audio. I changed it to Analog Audio and both the players were fixed after that change.


Audio might be muted. In VLC, right-click on the VLC screen, in the context menu select Audio and see if Mute is checked.

  • To add to this just try clicking on "Mute". I didn't notice any change in it showing whether it was checked or not after selecting. – user1071182 Nov 30 '16 at 7:26

As others have mention this is likely a restricted extras issue. The easiest way to install them is to open a terminal and type:

sudo apt-get install ubuntu-restricted-extras

You will need to select 'Ok' for the Microsoft EULA: just tab down until it's selected and press the Enter key.

  • Apparently that was not the issue. When I gave that command, I got "ubuntu-restricted-extras is already the newest version." – Joshua Fox Jun 25 '15 at 19:17
  • Are you using HDMI to watch the movies on another monitor? – Tamsyn Michael Jun 25 '15 at 22:42
  • Not using HDMI, just the laptop itself. – Joshua Fox Jun 26 '15 at 5:11

Same ditto problem was with me and I got it resolved in this way

Audio Settings -> Audio Device -> Changed it and switched back



Same thing happened to me with VLC and Totem in Ubuntu 16.04. However in some other players like mpv sound was working fine.

I had the feeling it had something to do with last time I opened VLC. I was watching a movie on the TV (by HDMI connection) so back then I configured the audio to be played by HDMI output. I powered off the laptop without reverting the configuration.

But now I was not connected to HDMI and in sound configuration only internal speakers were showing.

In the end, the configuration option to blame was to be found in VLC itself. While playing, Audio > Audio device > (select your internal speakers). I seems it did not revert itself to internal speakers, because HDMI output was still selected. Now even Totem is working.

I hope this experience helps someone!

  • this seemed to be my issue as well, except that to fix it i plugged back into the HDMI connection, then went to my audio settings and switched back to Speakers, then disconnected the HDMI. – Nick Briz Oct 3 '16 at 14:14

According to help.ubuntu::

No sound If you don't hear any sound, try: (a) click System -> Preferences -> Sounds. Then click a sound in the bottom list, and make sure that it's not already selected. You should hear the sound you selected. If not, make sure your speakers are working and that your volume is up. Try clicking another sound in the list, after ajusting your volume. Also make sure your speakers are working. Once you're done, select the sound it was on before and click OK. (b) downloading VLC Media Player by clicking Applications -> Ubuntu Software Centre or Applications -> Add/Remove Appications. Search for "VLC Media Player" and download the program with the orange cone icon. If you don't see an orange cone, the icon might be a cardboard box with all kinds of stuff sticking out of it. In that case, look at the discriptions. Install VLC and then use it to play your movie or DVD.

If this doesn't work, just try to install media codes.

  • Thanks. (A) I did try out the Sounds configuration GUI. With a movie playing in VLC, this GUI does show VLC, and even with the volume at max, no sound comes from the movie. (B) I have indeed installed VLC, and like other movie players, it does not work. – Joshua Fox Jun 19 '15 at 14:56

If you changed manually once the output in your sound settings (for me that was an HDMI audio controller to have the sound of my home cinema), disconnecting the HDMI cable and trying to hear back your built in audio card does not work. I had to connect back to the HDMI cable, change manually the output to my built in audio and then it worked.


Open nautillus. Open your home folder. Press Ctrl+H. Open the .config folder. Delete the vlc folder. Audio goes back to normal.


Sound Settings -> Applications -> See If 'Videos' Is Muted


First open any video Then Go to Settings --> Sound ---> Applications and increase the sound of your application (if lowered)


All my MP4s were "muted" for no apparent reason.

I found that I had previously configured the sound to go to the HDMI port, but this time HDMI was not attached. So I just used the "Settings" control panel, "Sound" section to re-select "built-in speakers".


u just need to connect the HDMI to an external input and go to settings>sound>output and choose the HDMI output then remove the HDMI cable and back again to the built in source it's just a bug


I'm running Debian jessie and had the exact same problem as original poster, Audacious & web browsers played audio, but VLC and GNOME Mplayer were muted. I had previously made a change to VLC preferences to capture stills from video. As far as I know, the only changes were the path and frame rate for the scene filter, plus enabled the scene video filter. When I tried to watch a movie with GNOME Mplayer, audio was muted. Audacious played the audio of the exact same mp4 no problem. I disabled the scene video filter and checked all the audio settings (default) in VLC. Still VLC and GNOME Mplayer did not have audio.

Since I usually run just the defaults in VLC, I clicked reset preferences, and I now have audio.


Go to video that you downloaded and then open one video with VLC. Then click audio, in the audio section there is muted, click it.

This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.