3

As of today,

  • Shift+2 gives me the @ symbol and Shift+' gives me ". (The at sign and the double quotation mark have swapped places.)
  • Alt Gr+4 no longer produces the € symbol.

This tells me that my keyboard has switched to some non-Irish mode, probably American. And yet, up at the top right of my screen I see an Ie, and if I click on it I see that the Irish option, which is the only option, is selected. What gives?

Screenshot of menu described above

The keyboard layout chart shows much as I’d expect, with the ", @, and € symbols where I’d expect to see them:

Keyboard layout chart: Title says "Irish"

And the text entry settings also show Irish as the only available option:

Import sources to use: Irish

So if everything tells me that I have an Irish keyboard, and if it worked as an Irish keyboard till yesterday, why is it suddenly not an Irish keyboard today? And what can I do about it?

1
3

First run:

sudo dpkg-reconfigure keyboard-configuration

to reconfigure the console keyboard layout. Then run:

sudo dpkg-reconfigure console-setup
2
  • €@". Wonderful. The first of those fixed the € problem (I explicitly told it to use the right alt key, rather than leaving it at default. I left all other options at default.) The second put @ and " in their proper places, though I'm at a loss to understand why. Why do console settings affect keyboard layout? Anyway, it works. Thanks. – TRiG Jun 19 '15 at 11:30
  • This happens often enough that I now have function fix_keyboard { sudo dpkg-reconfigure keyboard-configuration; sudo dpkg-reconfigure console-setup; } in my .bash_aliases. – TRiG May 3 '16 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.