The sna acceleration is default option and I want to go back to uxa because sna doesn't work after suspending on my laptop.

And it doesn't work just adding /etc/X11/xorg.conf.d/20-intel.conf which contains

"Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"

to make the switch.

After input: cat /var/log/Xorg.0.log | grep -ie uxa -ie sna in terminal. The output is:

[     4.142] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.6 (Timo Aaltonen <[email protected]>)
[     4.144] (II) intel(0): SNA initialized with Broadwell backend

And it seems that the UXA is not compiled or installed at the beginning.

Is there a way to switch to UXA under this situation?

  • This (Hibernation-error) is rather related to the Linux-Kernel than to the graphics driver. Please give also details what card in use. Jun 25, 2016 at 20:49

1 Answer 1


It seems your configuration file (/etc/X11/xorg.conf.d/20-intel.conf) has too much quotes.

Without surrounding quotes:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"

The uxa acceleration method should be used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .