I have a DisplayLink-based external USB monitor, which has both power and data over USB, and seems to work perfectly under Windows 7, but only can display a text console under Ubuntu 10.10, and that I can only use when I am actually switched to it. So the only Use I can have so far is to have some text-based monitoring or console that I can watch while working on the graphic display.

I know there are some development done for DisplayLink, but I never could get it to actually run properly.

Yes, I tried the detailed setup described in other posts, but they did not work, and instead crashed my X that I had to restore.

Merci :-)

  • Can you give us the name of your monitor? (manuf. and model) Oct 14, 2010 at 21:14
  • Mine s the iMo USB Sub-Monitor, as sold at ThinkGeek.com / The Model is actually the XT-7, as I can see on the CDROM.
    – jfmessier
    Oct 15, 2010 at 17:53
  • Which laptop/computer and graphics card do you have? I have an HP dv7 4183cl, and am trying to setup a triple head using 1 displaylink monitor.
    – user12046
    Mar 8, 2011 at 22:17
  • I would like to add that only USB2 Displaylink devices are supported in Linux, but the newer USB3 devices are NOT supported. More info here: askubuntu.com/questions/517339/…
    – noleti
    Aug 29, 2014 at 2:08

6 Answers 6


On Aug 3, 2015, Displaylink finally released the USB Monitor driver for Ubuntu.

Link: http://www.displaylink.com/downloads/ubuntu.php

I have an AOC usb monitor and Ubuntu 14.04. After installing the driver, my usb Monitor start working.

If the driver works for your monitor, please let other people know by posting it. Many people waiting for this driver. I've been waiting for 2 years. :-)

  • 1
    I've been waiting for four years now. Actually, the monitor is in some box somwehere in the home. But I will get the driver and see hw if works on my installation. I now use Ubuntu 15.04. Thanks for the link.
    – jfmessier
    Aug 19, 2015 at 11:10
  • It works for me on Ubuntu 14.04 after installing a more recent kernel than the standard one (sudo apt-get install linux-generic-lts-utopic). In my case, the monitors themselves do not use USB, but I use a Dell or HP docking station / port replicator to which I connect them. With compiz, the displays are not updated after each keystroke (only upon the next one), which is really annoying. With metacity, this problem does not occur. Oct 7, 2015 at 11:14
  • @user1715991 would you kindly tell us exactly what's your AOC monitor? Nov 4, 2015 at 15:25
  • Thank you so much (finally)! I can confirm this working with an HP NL571AA USB Graphics Adapter, Ubuntu 14.04.3 LTS 64-bit, and a HP 1955 19" (tertiary) monitor. I only had to switch from the binary NVIDIA drivers to the open source Nouveau ones to make it work. Nov 5, 2015 at 16:34
  • Also working here for a HP NL571AA on 16.04 64bit with Nouveau at 1920x1080 external res.
    – JLTD
    Aug 18, 2016 at 17:08

Maybe this will get you a little bit further.

General DisplayLink adapter information for Linux is available here.

Also, if your primary graphics adapter is from NVIDIA, you should read this.

Good Luck

  • Lots of useful links. Will take me some time to read it all and setup, but I htink I"m in the right way to get it working.
    – jfmessier
    Nov 6, 2010 at 13:00
  • @jfmessier, did you get it working? Feb 27, 2011 at 8:28
  • Not yet. All I can get so far is a graphical display, but then the other monitors are black, useless. I still have to merge the configuration files together. My existing xorg.conf file is empty, and if I put the config file for the DisplayLink, it disables everything. So I need to generate the xorg.conf file for my existing monitors and then figure out how to append the DisplayLink stuff in it. BTW: I now have an ATI-based dual-monitor display, while I used to only connect to the on-board Intel-based adapter.
    – jfmessier
    Mar 7, 2011 at 19:52
  • 2
    I see it's been a while since this was updated. Would you mind telling me whether DisplayLink USB monitors work well for you with current software?
    – Ken Kinder
    Jun 4, 2012 at 18:55
  • 1
    @Ken, they work out of the box only on Linux 3.9 and later which ships in Saucy Salamander.
    – Shnatsel
    Aug 29, 2013 at 0:39

UPDATE: April 2019 -> DisplayLink with kernel > 5.0.5 also works.

UPDATE: March 2019 -> DisplayLink with kernel > 4.18.20

It is now possible to install the driver with new versions of kernels. I am writing this after updating to 4.20.13

You will have to use a script, however, which you can obtain from HERE (Github).

Once you have the script, remove the currently installed driver/module and install the new version. Script will download all dependencies for you. To remove old/install new apply the below steps:

sudo ./displaylink-debian.sh --uninstall
sudo dkms remove evdi/1.6.0 --all -q
sudo systemctl stop dlm.service
sudo systemctl disable dlm.service
sudo rm -f /lib/systemd/system/dlm.service
sudo rmmod evdi
sudo displaylink-debian.sh --install


February 2019 -> Ubuntu 18.04 LTS


Download driver from HERE. Then unzip, make sure it's runable and install (change the below file names to your versions):

$ unzip DisplayLink USB Graphics Software for Ubuntu 4.4.zip
$ chmod 775 displaylink-driver-4.4.24.run
$ ./displaylink-driver-4.4.24.run

Thats it! Once installed you can connect your DisplayLink to the PC and it should fly.

Few notes:

Make sure you have dkms installed on your system.

$ sudo dpkg -l | grep dkms
ii  dkms          2.3-3ubuntu9.2        all          Dynamic Kernel Module Support Framework

Also note, it works perfectly with the 4.15.0-45-generic kernel. However, I tried with the newest kernel 4.20 and the driver will not work - evdi for dkms will not compile. I haven't tried other kernels - if I try I will update the answer - but beware of this issue!

You can check your current kernel like this:

$ uname -r

EDIT: (14.02.2019)

Ok, so I decided to try some kernels and it seems that 4.18.20-041820-generic is the most recent working. Nothing higher worked for me.


Here's an easy way to test if your DisplayLink device is operable at a low level, under Linux. If you plug in the device and get a green screen, you're ready for the next step.

First convert a bitmap to the size of your screen, then convert it to 16 bit RGB color. Then copy to the framebuffer for the device:

convert -resize '800x480!' input.jpg temp1.png
mkdfiff -f RGB16 temp1.png > temp2.png
dd if=temp2.png of=/dev/fb1

Note that your DisplayLink is probably at /dev/fb1, but you can check with dmesg :

[581145.816821] udlfb: DisplayLink Kensington M01063 - serial #202241900817
[581145.817000] udlfb: vendor descriptor length:22 data:22 5f 01 0020 05 00 01 03 00 04
[581145.817005] udlfb: DL chip limited to 2360000 pixel modes
[581145.909488] udlfb: DisplayLink USB device /dev/fb1 attached. 800x480 resolution.

Only version 1 DisplayLink chips are supported by Linux. The DisplayLink 1 chips are limited to 16 bit RGB. Getting the device to work properly under X windows is more challenging.

  • thank you the above confirmed my monitor can work. I wish there was a write up on how to install if though
    – vishal
    Oct 2, 2014 at 15:12
  • You can use the framebuffer directly from VLC: vlc --vout fb --no-fb-tty --fbdev /dev/fb1 video.mp4
    – 13rac1
    Apr 25, 2016 at 8:11

In addition to callmebob's installtion guide on 18.04 I had to do the following routine: Workaround 1: Disable PageFlip for modesetting

It is preferred to keep using "modesetting" driver, but disabling page flipping is necessary. To do this, as a root user create a file 20-displaylink.conf under:


with the following content:

Section "Device"
  Identifier "DisplayLink"
  Driver "modesetting"
  Option "PageFlip" "false"

A reboot is required for the setting to be effective.


Don't forget to disable Secure Boot (UEFI) if you have it enabled. Here's a guide:



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .