Cheese just doesn't detect the webcam .. nor other software. This is an MSI GT70 2PC. I cannot even find someone having the problem. The webcam even works fine on windows 8.1 .

I also tried adding the user to the video group and I even tried this:

sudo chmod 777 /dev/video*

following this question but ubuntu can't find the directory in the first place!


Maybe the camera is locked. I own a MSI GS70-2PC-210US and from time to time this happens to me after doing updates.

Try pressing Fn+F6 (or whatever the camera lock/unlock button is located on your keyboard).

  • that was the problem. Thanks – user2992476 Oct 31 '19 at 7:55
  • same, bravo. after all the problems i had with the audio drivers where i have to console type alsadriver every time to hear the speakers i was expecting the worst scenario – Mr-Programs Feb 11 '20 at 18:46
  • Wow, would have never tried that. Thanks for the tip! – Try431 Mar 20 '20 at 0:49

Try going on "additional drivers" (you can search for it on the Ubuntu search engine) and looking for any proprietary drivers for your device. It usually works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.