0

I am using ubuntu precise. Python version installed on this version is 2.7.6. But Cloudera expected 2.7.3. I just followed this. Entire system became non-functional. I couldn't even able to install jdk. What i want is I want to revert this change. Somehow I need to get back to default 2.7.6.

Any suggestions?

EDIT1

E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg -C returns

 The following packages have been unpacked but not yet configured.
 They must be configured using dpkg --configure or the configure
  menu option in dselect for them to work:
 libgnome2-0:amd64    The GNOME library - runtime files
libgnome2-bin        The GNOME library - binary files
libgnome2-common     The GNOME library - common files
libgnomevfs2-0:amd64 GNOME Virtual File System (runtime libraries)
libgnomevfs2-common  GNOME Virtual File System (common files)

The following packages are only half configured, probably due to problems
configuring them the first time.  The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
gconf2               GNOME configuration database system (support tools)

If i try to reconfigure, then its like a cyclic error. Finally It points Python IO module error

EDIT2

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    python is already the newest version.
    The following packages were automatically installed and are no longer required:
      gcc-4.8-base:i386 libasan0:i386 libatomic1:i386 libc6-dev:i386 libgcc-4.8-dev:i386 libgmp-dev:i386 libgmpxx4ldbl:i386 libgnutls-dev:i386 libgnutls-openssl27:i386
      libgnutls28-dev:i386 libgnutlsxx28:i386 libgomp1:i386 libitm1:i386 liboath-dev:i386 liboath0:i386 libopenconnect3:i386 libp11-kit-dev:i386 libproxy-dev:i386
      libproxy1:i386 libquadmath0:i386 libstdc++-4.8-dev:i386 libstoken-dev:i386 libstoken1:i386 libtasn1-6-dev:i386 libtomcrypt-dev:i386 libtomcrypt0:i386 libtommath0:i386
      libxml2:i386 libxml2-dev:i386 linux-libc-dev:i386 nettle-dev:i386 zlib1g-dev:i386
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 293 not upgraded.
    6 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Setting up gconf2 (3.2.6-2ubuntu1) ...
    /var/lib/dpkg/info/gconf2.postinst: 74: /var/lib/dpkg/info/gconf2.postinst: gconf-schemas: not found
    dpkg: error processing package gconf2 (--configure):
     subprocess installed post-installation script returned error exit status 127
    dpkg: dependency problems prevent configuration of libgnomevfs2-common:
     libgnomevfs2-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.

    dpkg: error processing package libgnomevfs2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnomevfs2-0:amd64:
     libgnomevfs2-0:amd64 depends on libgnomevfs2-common (= 1:2.24.4-6ubuntu1); however:
      Package libgnomevfs2-common is not configured yet.

    dpkg: error processing package libgnomevfs2-0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnome2-common:
     libgnome2-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.

    dpkg: error processing package libgnome2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnome2-0:amd64:
     libgnome2-0:amd64 depends on libgnomevfs2-0 (>= No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                                       No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                     No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                                                                                                       1:2.17.90); however:
      Package libgnomevfs2-0:amd64 is not configured yet.
     libgnome2-0:amd64 depends on libgnome2-common (>= 2.32); however:
      Package libgnome2-common is not configured yet.
     libgnome2-0:amd64 depends on libgnome2-common (<< 2.33); however:
      Package libgnome2-common is not configured yet.

    dpkg: error processing package libgnome2-0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnome2-bin:
     libgnome2-bin depends on libgnome2-0 (>= 2.17.3); however:
      Package libgnome2-0:amd64 is not configured yet.

    dpkg: error processing package libgnome2-bin (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     gconf2
     libgnomevfs2-common
     libgnomevfs2-0:amd64
     libgnome2-common
     libgnome2-0:amd64
     libgnome2-bin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
0

Probably, you have getting issues to reinstall the python from the apt-get because the tarball instalation has created the files used in python

You can download the python package and its dependences, put all the files in the same directory and use dpkg to install overwriting the existent files:

  1. To get the requeride package, you can just run apt-get install python just for get the list of the packages that apt would install.

  2. To download them, use apt-get download [paste here the list of the packages] command in a empty folder

  3. And to install, use in this same folder: dpkg --force-overwrite -i *.deb

I hope that it will work. Good luck.

Edit: My answer didn't considers that edit. You must fix the problems that you got with libgnome* packages before try above.

2
  • Thanks Man. After the first step I am getting some errors. Can you please see the edits – Gibbs Jun 18 '15 at 5:51
  • Yes Danil, That is what i said If i try to fix that, It says python IO error – Gibbs Jun 18 '15 at 5:53
0

As I see in another post that you consider a ubuntu re-install, then you might try the following:

$ dpkg --list | grep -i python > ~/pythonpackages.txt
$ ### txt file just to review what was installed
$ sudo apt-get purge python*          #remove all python related packages
$ sudo rm -rf /var/lib/apt/lists      #remove apt information
$ sudo updatedb                       #refill the file location database
$ locate python                       #find all python related files
$ # remove all directories and files that you find with python
$ apt-get update
$ apt-get install python

Note: This is not a clean cleanup or revert, but more brute removal of whatever has to do with python. So you can retry installing all your python packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.