2

I recently installed a firewall called "firewall-applet" and now I can't share my internet through ethernet cord I tried all of these with no success

sudo apt-get --purge  remove firewall-applet
sudo iptables -F
sudo ufw disable

next I did nmap localhost

Not shown: 996 closed ports

PORT STATE SERVICE

23/tcp open telnet

25/tcp open smtp

139/tcp open netbios-ssn

445/tcp open microsoft-ds

I tried reinstalling the program there's no way to disable the firewall

please help ;(

  • what are you trying to do exactly ? – Panther Jun 18 '15 at 2:38
0

Firewall-applet is a tray applet for firewalld. Check to see if firewalld is running on your host. Firewall-applet and firewalld are both installed separately, so there is a good chance when you remove firewall-applet, firewalld is still installed and running.

ps -ef | grep firewalld

if it is running, you can remove it by typing in:

sudo apt-get remove firewalld

Hope that helps.

  • that does not really open a port nor configure sharing a network connection nor configure NAT. Why are we removing something rather then understanding what the OP wants and advising configuration. – Panther Jun 18 '15 at 2:55
  • @bodhi.zazen because he set up a firewall and wants to remove them. I was only trying to help remove what was the back for the firewall-applet, that is all. – Terrance Jun 18 '15 at 2:57
  • @bodhi.zazen they are two different applications. Firewalld is installed separately then firewall-applet. The manpage shows it as a tray applet for firewalld. manpages.ubuntu.com/manpages/trusty/man1/firewall-applet.1.html – Terrance Jun 18 '15 at 3:01
  • I am familiar with such things. IMO you should be explaining how to configure firewalld, either with the applet or any way you wish. – Panther Jun 18 '15 at 3:36
  • @bodhi.zazen He asked to remove the firewall, that is what he asked. I gave an answer. – Terrance Jun 18 '15 at 3:40
1

firewalld can be controlled through the firewall-cmd tool. To open port 22 temporarily use:

sudo firewall-cmd --add-port=22/tcp

To add it permanently (so it remains open when you reboot), you will also need to use:

sudo firewall-cmd --permanent --add-port=22/tcp

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.