3

After a fresh ubuntu install I had some problems with the mouse flickering and disappearing. I intalled the AMD drivers from AMD's website but after restart I got a graphics error so had to remove the installed drivers. After that I installed the radeon drivers so I was able to get my screen back up. The mouse is stopped flickering but my second monitor is not detected by ubuntu.

I tried to debug this but found no solution.

lshw -c video:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. 
[AMD/ATI] Pitcairn PRO [Radeon HD 7850] [1002:6819]

sudo lshw -c video:

  *-display               
       description: VGA compatible controller
       product: Pitcairn PRO [Radeon HD 7850]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:48 memory:e0000000-efffffff memory:f7c00000-f7c3ffff ioport:e000(size=256) memory:f7c40000-f7c5ffff
  *-display
       description: Display controller
       product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:47 memory:f7800000-f7bfffff memory:d0000000-dfffffff ioport:f000(size=64)

xrandr:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
DFP5 disconnected (normal left inverted right x axis y axis)
DFP6 disconnected (normal left inverted right x axis y axis)
DFP7 disconnected (normal left inverted right x axis y axis)
CRT1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1360x1024      60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       75.0     60.0  
   1280x900       75.0     60.0  
   1360x768       59.9  
   1280x800       59.8  
   1152x864       60.0     75.0  
   1280x768       59.8  
   1280x720       60.0  
   1024x768       75.0     70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     67.0     59.9  

I'm a total beginner on desktop ubuntu, used linux only for hosting. I have a i7-3770 processor and Radeon HD 7850 VGA.

3
  • Please run xrandr in terminal and report back. – nutty about natty Jun 22 '15 at 6:18
  • Also, if you haven't yet expended a lot of time and effort setting up your system, perhaps consider starting from scratch again: clean install with no extra drivers. This may simplify the troubleshooting... – nutty about natty Jun 22 '15 at 6:20
  • Finally I arrived at home, added xrandr. Sadly I don't want to reinstall it because I used it for 2 weeks with that mouse problem but one day I really got tired of it and wanted to solve the problem once for all. :S – Lakatos Gyula Jun 24 '15 at 19:37
1
+100

You will probably need to mess around with your xorg.conf file.

However, you have 2 different GPUs by the look of it. Of course, you won't manage to use 2 X Screens, and for me Xinerama didn't work.

I got mine to work (1 screen on each GPU) by not specicifically referencing the second GPU. I (however) am using 2 nVidia GTS 450s, and 2 identical screens, so you may struggle with that method.

Here is what you need for an xorg.conf file:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

This sets up the layout. Note how we only have 1 screen (with the location 0,0) and Xinerama is disabled (set to "0").

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

This is the section for your mouse and keyboard. Your xorg.conf file (if it exists) should already have this. If not, just use this. It should work, as this seems to be a default.

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer S220HQL"
    HorizSync       31.0 - 82.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

The monitor section is likely to be different for you - keep the name the same, and leave DPMS alone, but the Name and the HorizSync / VertRefresh will probably be different for you.

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 450 GTS"
    BusID          "PCI:1:0:0"
EndSection

Now I tell it my GPU exists. This may be the issue for you, and I think(?) your GPUs are different. Anyway, the key for me was only to tell it that there is one GPU.

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "GPU-56281125-01c7-ee85-b8b9-b3e5cf94b7c5.GPU-0.DVI-I-0: 1920x1080 +0+180, GPU-cbc59e3f-e8c1-a347-a069-b62f6b885f7d.GPU-1.DVI-I-0: 1920x1080 +1680+180"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Finally, the screen section. This is where the second GPU appears. I don't know what the 56281125-01c7-ee85-b8b9-b3e5cf94b7c5 means, and this may just be a name. The 1920x1080 is your screen resolution, and the +1680+180 is really confusing, but essentially positions it. Why it's 1680 I don't know.

MultiGPU is off, as is SLI, but BaseMosaic is on. I guess the Depth is the colour depth.

I've stuck this all together in a paste bin, here for you.

-1

Screen 0 is behaviour of Ubuntu, when inproper or none (standard) graphical driver is present.

In general for this situation is necessary to install additional drivers. For Nvidia drivers you have to search for additional drivers in Ubuntu software center - settings - software sources - additional drivers // english names in menu are not exact.

As you have Radeon card, you can follow already answered question here: How to install drivers for AMD Radeon HD 7850?

-2

I'm afraid I do most things in the GUI, and not the CLI, where possible, but here is how I solved a similar problem.

  • Firstly plug in and switch on the monitor (as I'm sure you're doing, but the order is important).
  • Open the Application 'Screen Display'
  • Press the button 'Detect Displays'
  • From there your second monitor should be ready for use, and it is just a matter of setting it up to suit your requirements. I searched for how to do this here in ask Ubuntu and ended up using Compiz Manager to force applications to the second screen using a keyboard short-cut.
2
  • 1
    Thanks for the reply but sadly I tried this already a few times. :( I think my second monitor is controlled by "Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller" and that's why its not visible. :( – Lakatos Gyula Jun 26 '15 at 15:04
  • Not a solution when graphics card cannot detect VGA output and just generic Screen0 is present. – Dee Jun 27 '15 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.