11

I got spinning 5400 rpm 1Gb drive.

Booting takes 69 seconds (is it slow?) and /var/lib/ureadahead contains empty directory debugfs. That is why I wonder if ureadahead does its job.

/var directory is on root partition

~ > df
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda7        24G   15G  8,1G  65% /
udev            3,9G  4,0K  3,9G   1% /dev
/dev/sda9       705G  143G  562G  21% /data
/dev/sda8        29G   24G  4,2G  85% /home

configs seem to be default

~ > cat /etc/init/ureadahead.conf|grep -v '#'|grep -ve '^$'
description "Read required files in advance"
start on starting mountall
stop on stopped rc
expect fork
kill timeout 180
normal exit 0
exec /sbin/ureadahead --daemon
pre-stop exec sleep 45

~ > cat /etc/init/ureadahead-other.conf|grep -v '#'|grep -ve '^$'
description "Read required files in advance (for other mountpoints)"
start on mounted DEVICE=[/UL]* MOUNTPOINT=/?*
expect fork
normal exit 0 4
exec /sbin/ureadahead --daemon $MOUNTPOINT

Strangily /var/log/upstart/ureadahead.log.1.gz contains almost only "Ignored relative path" or "No such file or directory" tagged entries.

root:/var/log# zcat upstart/ureadahead.log.1.gz |grep -v "Ignored relative path"
Counted 4 CPUs

ureadahead:/data/swapfile: Error retrieving chunk extents: Operation not supported
ureadahead:/var/lib/NetworkManager/dhclient-eth0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-eth0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory
ureadahead:/etc/X11/xorg.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-eth0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-eth0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory
ureadahead:/usr/share/X11/xorg.conf.d/20-intel.conf: No such file or directory
Counted 4 CPUs

ureadahead:/data/swapfile: Error retrieving chunk extents: Operation not supported

On bootchart ureadahead appears on 16th second and lasts less than a second. Compare to https://superuser.com/questions/286571/ubuntu-slow-startup-time-modprobe where ureadahead starts immediately after plymouthd

bootchart.jpg

UPDATE 1 Add blockdev report

# blockdev --report
RO    RA   SSZ   BSZ   StartSec            Size   Device
rw   256   512  4096          0   1000204886016   /dev/sda
rw   256   512  4096       2048       524288000   /dev/sda1
rw   256   512  4096    1026048        41943040   /dev/sda2
rw   256   512  4096    1107968       134217728   /dev/sda3
rw   256   512  4096    1370112       524288000   /dev/sda4
rw   256   512  4096    2394112    171795546112   /dev/sda5
rw   256   512  4096 1927233536     13460267008   /dev/sda6
rw   256   512  4096  337932288     26214400000   /dev/sda7
rw   256   512  4096  389132288     31457280000   /dev/sda8
rw   256   512  4096  450572288    756050558976   /dev/sda9
rw   256   512   512          0      1073741312   /dev/sr0

Partitions /dev/sda1 - /dev/sda/6 are windoze, ESP, DIAGS, WINRETOOLS, PBR Image

  • I ended up disabling the service: sudo systemctl disable ureadahead.service. This is Ubuntu 16.04 with kernel 4.4 – dashesy Oct 13 '16 at 1:28
  • can you provide your dmesg output? – Gewure Oct 16 '16 at 22:34
2

This version of ureadahead has been around since at least the start of 2015 and I doubt it was written with systemd in mind. I don't know what bumped the minor versions but last commits are from 2010. They probably included some of the merge requests since your version is reporting cpu count.

The dev is now working for Google.

Your best bet at this point would be to keep it disabled. If looking to shave off a couple seconds off boot, remove wpa_supplicant if not needed.

| improve this answer | |
  • Ubuntu has given up on ureadahead as of cosmic. Just "apt purge utreadahad: and be happy, – rfm Oct 25 '18 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.