I am entering the correct password in Ubuntu, but the screen just blinks and again shows me the same login screen. Guest session works properly. What should I do?

  • Is there a incorrect password message? If no, Type alt+ctrl+F1. You will go to linux console. Try typing your password there. Let us know if you are still unable to login.
    – Jay
    Jun 17, 2015 at 11:46
  • Check this problem and the solution: askubuntu.com/questions/145333/…
    – Jay
    Jun 17, 2015 at 11:49
  • - caps lock? - incorrect keyboard. Did you use a char different than 0-9, a-z, A-Z?
    – Rinzwind
    Jun 17, 2015 at 14:37
  • 5
    Since the original title was "..not aacpting..." I have to ask: Does your keyboard "a" key stutter; and is there an "a" in your password?
    – waltinator
    Jun 17, 2015 at 23:46
  • After rename the .XAuthority, If it doesn't worked yet, if your password is number, try to enter it by using numpad instead of top keyboard horizontal number keys.
    – Andiana
    Jul 31, 2017 at 7:17

2 Answers 2


This doesn't always work, but going into the Linux console mentioned by Jay (ctrl+alt+F1), and moving/deleting .Xauthority in your home directory (example: /home/arpan/.Xauthority) may help.

I've had this problem on my own computer, and it fixed it. However, this same problem arose on another computer, and this did not resolve the problem.

  • My keyboard has no stutter and I do not have the CAP-lock on. While having a sudden problem in 23.04 on a system that was up and running but now booting only to a black screen and no login page at all, I booted to the Safe mode where it does does get the login but does not accept my password while in terminal mode it does. Not sure why that is.
    – DonP
    Nov 18, 2023 at 23:19

It is not so obvious that the wrong password was entered. Today, I had the same problem with Ubuntu 16.04 (on VirtualBox on a Windows 10 host) after the screen was locked automatically. Entering the password in the graphical interface kept giving me the message the password was wrong. Logging in via the console worked just fine, just as well as logging in from the host machine over ssh with the same username. Hence, the password was not the problem.

I solved the problem by restarting the device with the shutdown command from the console (can be done over SSH as well if necessary and if a SSH server is running on your machine).

Not the answer you're looking for? Browse other questions tagged .