20

Right now my external drive does not has any errors but I just want to check manually to make sure.
As seen from image below, the option for SMART data and Self-Test is greyed out. Also see the details about the hard drive in image itself.

  1. I tried running gksu gnome-disks but still the option is greyed out.

  2. I ran sudo smartctl --all /dev/sdb --test=short -T permissive I got this error:

    smartctl 6.4 2014-10-07 r4002 [x86_64-linux-3.19.0-15-generic] (local build)
    Copyright (C) 2002-14, Bruce Allen, Christian Franke,
    www.smartmontools.org
    
    Read Device Identity failed: scsi error unsupported field in scsi
    command
    
    === START OF INFORMATION SECTION ===
    Device Model:     [No Information Found]
    Serial Number:    [No Information Found]
    Firmware Version: [No Information Found]
    Device is:        Not in smartctl database [for details use: -P
    showall]
    ATA Version is:   [No Information Found]
    Local Time is:    Wed Jun 17 11:33:46 2015 IST
    SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't
    show if SMART supported.
    SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't
    show if SMART is enabled.
    
    A mandatory SMART command failed: exiting. To continue, add one or
    more '-T permissive' options.
    

screenshot

2
  • 1
    Same problem here. I can add that it happens in Ubuntu 14.04, but NOT in Ubuntu 12.04 where SMART is correctly read by both the GUI and the command line. Any ideas? Nov 2, 2015 at 9:05
  • 1
    Found the solution, see my answer Nov 2, 2015 at 11:43

5 Answers 5

19

I had the same problem. In my case, S.M.A.R.T had been working properly on the device for years while using Ubuntu 12.04, and then under Ubuntu 14.04 it happened exactly what you tell in the question.

The problem is related to a new kernel module that was introduced in Linux Kernel 3.15 called uas (USB Attached SCSI) (see release announcement).

That module is now the responsible of managing USB Mass Storage Devices. There is a thread where people complain that uas in kernel 3.15 is causing their USB devices to fail. Another one says that it might be the cause of S.M.A.R.T problems.

Fortunately, those problems seem to be gone at kernel 3.19 (which I am using), as my device is being detected correctly. Only the S.M.A.R.T problem remains.

To fix it, you need to disable the use of uas module for the given device.

Disable uas without rebooting

First, unplug all USB devices that might be using it. Then, remove the uas and usb-storage modules:

sudo modprobe -r uas
sudo modprobe -r usb-storage

Then, load usb-storage module with a parameter that tells it to not use uas for a given device:

sudo modprobe usb-storage quirks=VendorId:ProductId:u

VendorId and ProductId must be replaced by your device vendor and product id, which can be obtained with lsusb command (they are the characters after ID).

For example, I have the following device:

Bus 002 Device 011: ID 0bc2:3320 Seagate RSS LLC SRD00F2 [Expansion Desktop Drive]

So my vendor id is 0bc2, and my product id is 3320. My command is:

sudo modprobe usb-storage quirks=0bc2:3320:u

The last u tells usb-storage to ignore uas for the device (see source).

At this point, you can insert the USB device, and it will know not to use uas, making S.M.A.R.T work properly. You will see lines like these in dmesg when inserting the USB device:

usb 2-2: UAS is blacklisted for this device, using usb-storage instead
usb-storage 2-2:1.0: USB Mass Storage device detected
usb-storage 2-2:1.0: Quirks match for vid 0bc2 pid 3320: 800000
scsi host12: usb-storage 2-2:1.0

Make the change permanent

The previous quirk will only last until you reboot the system. To make it persistent, you need to follow the steps described here, which I copy below:

First, create a file named ignore_uas.conf in the /etc/modprobe.d/ directory with the following content:

options usb-storage quirks=VendorId:ProductId:u

As before, substitute VendorId and ProductId by your device vendor and product id obtained from lsusb.

Next, regenerate your inital ramdisk:

mkinitcpio -p linux

or, on newer Ubuntu versions:

sudo update-initramfs -u

Finally, reboot your computer.


Edit: More background on the issue, and another way to get around it without disabling uas (which has better throughput than usb-storage) can be found here: https://www.smartmontools.org/ticket/971#comment:12

It seems that kernel is blacklisting SAT ATA PASS-THROUGH on some devices when running in uas mode, as they have broken firmware.

So, the blacklisting can be disabled (at your own risk) by using the previous method I mention in the answer, but removing the final u from the quirk, ie:

quirks=VendorId:ProductId:

Please note, however, that I have not tested this approach.

14
  • 2
    No mkinitcpio in 16.04. Ain't it "sudo update-initramfs -u" instead now?
    – filofel
    Oct 13, 2016 at 8:00
  • 1
    Great answer! I am able to access my Seagate USB drive and get all the smartctl data from it. I did try your edit there with the removal of the u and that unfortunately hung the drive so I couldn't get any SMART data and the boot time was slow. However, I added back the u and it works perfect.
    – Terrance
    Mar 6, 2019 at 15:18
  • 2
    Does disabling UAS make it degrade to USB block storage? UAS is drastically faster! UAS supports native command queuing and concurrent USB 3.0 streams, USB block storage is a completely sequential one-at-a-time protocol and uses a simple interrupt pipe.
    – doug65536
    Aug 31, 2019 at 2:56
  • 1
    For more than one, it looks like: quirks=0bc2:ab24:u,0bc2:ac30:u
    – Tom Hale
    Sep 12, 2019 at 15:02
  • 1
8

External drives (via USB, I assume) are tricky with SMART. Some don't work at all. The smartmontools people posted a list of hard drives with command-line switches to add to smartctl (see fifth column).


For Seagate Expansion drives in particular, it looks like you need either -d sat or -d sat,12. Try the following:

sudo smartctl -d sat --all /dev/sdb
sudo smartctl -d sat,12 --all /dev/sdb

If one of those works, it tells you which -d switch to add to your smartctl commands.

6
  • 3
    both are giving me error link Jun 17, 2015 at 6:55
  • the name of external hdd is : Seagate Expansion External. it seems to be supported but still the options are giving error Jun 17, 2015 at 6:57
  • @EdwardTorvalds Did you figure it out? 0x0bc2:0x331a doesn't work with these either.
    – endolith
    Jan 23, 2021 at 3:35
  • @endolith nah man. Jan 24, 2021 at 14:37
  • @EdwardTorvalds I temporarily disabled UAS smartmontools.org/wiki/SAT-with-UAS-Linux
    – endolith
    Jan 24, 2021 at 16:19
4

I had two Seagate drives connected so I modified @Terrance command to:

echo "options usb-storage quirks=$(lsusb | awk '/Seagate/ {print $6":u"}' | tr '\n' ',' | head -c-1)" | sudo tee -a /etc/modprobe.d/ignore_uas.conf

Which gives a correct separator (and flag repetition) for multiple elements:

options usb-storage quirks=0bc2:3320:u,0bc2:2323:u

This substitution of 'newline' characters by ',' is probably not made in the most elegant way (requires to remove the extra separator using head), but it seems to work.

Then:

sudo update-initramfs -u

And reboot as in original answer.

1
  • Good find! I didn't think about multiple drives at the time I tested mine. I really like this! +1
    – Terrance
    Aug 27, 2019 at 13:59
3

Just an update I am adding on to Alvaro's answer

Just tested this in Ubuntu 18.04 for an external Seagate drive that I have where I could not get smartctl to read the drive at all. It did require a reboot because I did not want to get behind my system and mess with the USB connections.

First ran lsusb and got all my info for the drive:

terrance@terrance-ubuntu:~$ lsusb
Bus 006 Device 002: ID 0bc2:a0a4 Seagate RSS LLC Backup Plus Desktop Drive
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 1532:0118 Razer USA, Ltd 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 046d:c215 Logitech, Inc. Extreme 3D Pro
Bus 003 Device 002: ID 1532:005b Razer USA, Ltd 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

As you can see my drive has the name Seagate in it, so all I had to do is to run the following line to add the info to the /etc/modprode.d/ignore_uas.conf file:

echo options usb-storage quirks=$(lsusb | awk '/Seagate/ {print $6}'):u | sudo tee -a /etc/modprobe.d/ignore_uas.conf

Just remember to replace Seagate with the name of your drive. Now when I look at /etc/modprode.d/ignore_uas.conf I see it as:

~$ cat /etc/modprobe.d/ignore_uas.conf 
options usb-storage quirks=0bc2:a0a4:u

Then just run the update-initramfs for the changes to become permanent:

sudo update-initramfs -u

Then reboot your system. Now the smartctl is able to read my external drive.

$ sudo smartctl -a /dev/sdf
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.15.0-43-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Seagate Barracuda 7200.14 (AF)
Device Model:     ST3000DM001-1E6166
Serial Number:    W1F3DNG2
LU WWN Device Id: 5 000c50 06a323610
Firmware Version: SC47
User Capacity:    3,000,592,982,016 bytes [3.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Form Factor:      3.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is:    Fri Jan 11 23:07:43 2019 MST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
See vendor-specific Attribute list for marginal Attributes.

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                    was never started.
                    Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                    without error or no self-test has ever 
                    been run.
Total time to complete Offline 
data collection:        (  592) seconds.
Offline data collection
capabilities:            (0x73) SMART execute Offline immediate.
                    Auto Offline data collection on/off support.
                    Suspend Offline collection upon new
                    command.
                    No Offline surface scan supported.
                    Self-test supported.
                    Conveyance Self-test supported.
                    Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                    power-saving mode.
                    Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                    General Purpose Logging supported.
Short self-test routine 
recommended polling time:    (   1) minutes.
Extended self-test routine
recommended polling time:    ( 336) minutes.
Conveyance self-test routine
recommended polling time:    (   2) minutes.
SCT capabilities:          (0x3081) SCT Status supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   108   099   006    Pre-fail  Always       -       19766104
  3 Spin_Up_Time            0x0003   094   091   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   097   097   020    Old_age   Always       -       3944
  5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   052   048   030    Pre-fail  Always       -       231936780154
  9 Power_On_Hours          0x0032   058   058   000    Old_age   Always       -       36793
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   020    Old_age   Always       -       3942
183 Runtime_Bad_Block       0x0032   100   100   000    Old_age   Always       -       0
184 End-to-End_Error        0x0032   100   100   099    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Command_Timeout         0x0032   100   092   000    Old_age   Always       -       894 897 1362
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   056   039   045    Old_age   Always   In_the_past 44 (Min/Max 44/44 #237)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   099   099   000    Old_age   Always       -       3909
193 Load_Cycle_Count        0x0032   020   020   000    Old_age   Always       -       161838
194 Temperature_Celsius     0x0022   044   061   000    Old_age   Always       -       44 (0 13 0 0 0)
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
240 Head_Flying_Hours       0x0000   100   253   000    Old_age   Offline      -       8558h+07m+38.053s
241 Total_LBAs_Written      0x0000   100   253   000    Old_age   Offline      -       14574986552
242 Total_LBAs_Read         0x0000   100   253   000    Old_age   Offline      -       18776308038

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Hope this helps!

7
  • After this change my drive won't mount anymore. Why ? Jan 7, 2020 at 15:53
  • @PhilippeDelteil I have never heard of that causing the drive not to mount properly. You can try askubuntu.com/a/952275/231142 to set up a more permanent if the drive is seen in gnome-disks.
    – Terrance
    Jan 7, 2020 at 20:34
  • The issue with this answer is that you will loose the performance associated with the uas driver. Jan 19 at 10:48
  • @HenriquedeSousa I have now tested your statement with my USB drive both ways and they produce the exact same speed with it enabled or disabled.
    – Terrance
    Jan 19 at 15:10
  • Which I could edit my comment as I forgot to add in order to be read "(..) theoretically you will loose the performance". What's the driver reported for the device in lsusb -tv ? Jan 19 at 17:37
1

check the table with supported USB Devices ...

the switch -d sat indicates, that it's supposed to be a drive with SATA port.

there are specific switches for certain USB bridges - lsusb might show the concrete name. if the bridge controller might have a bad implementation - just try to connect it native through SATA instead of USB.

SCSI and ATA (according to the shell output) are probably not what you are looking for :)

6
  • I am using cable which came with hdd when i bought it. you might wanna see these errors: link Jun 17, 2015 at 6:56
  • the name of external hdd is : Seagate Expansion External. it seems to be supported but still the options are giving error Jun 17, 2015 at 6:57
  • @edwardtorvalds there are two basic preconditions... having SMART enabled in BIOS/UEFI for the port (if applicable) and to have it enabled through software, before trying to read it... smartctl -T permissive --smart=on /dev/sdb (while the logs look like it would be talking to the wrong port) Jun 17, 2015 at 7:07
  • there is no boot option for that, i tried above command i got this error Jun 17, 2015 at 7:09
  • @edwardtorvalds seems it's still sending SCSI commands... that -d sat switch is missing smartctl -d sat -T permissive --smart=on /dev/sdb ...and as I've wrote above lsusb should list which bridge it is. Jun 17, 2015 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.