0

Tried to install steam and the terminal keeps throwing up this password confirmation. I type in the password I set and it starts "..............." then ends with"

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages."

note This is the first time I used Linux as an operating system. I'm much more familiar with windows command structure. ~Be gentle.

1

open a terminal and run:

sudo apt-get remove --purge libglapi-mesa:i386 libcheese-gtk23 libcheese7
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libglapi-mesa:i386 libcheese-gtk23 libcheese7
sudo apt-get install steam
0

The above answer should work, although I personally ran into some problems when attempting it. What worked for me was running the install from the terminal, rather than downloading the .deb from steampowered.com. All I did was run sudo apt-get install steam -y to get it installed. It loaded the EULA in the terminal, press tab a couple of times to select ok, then watch it load. Once installed, it should start automatically, update everything, and work. Hope this helps, just in case the above answer doesn't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.