1

So I've recently installed Ubuntu as a secondary operating system on my computer alongside windows 8.1, and I've discovered that it refuses to boot up with my Nvidia 960 GPU installed. I've repeatedly installed and reinstalled the 349 driver by taking out the GPU and using the commands:

sudo add-apt-repository ppa:mamarley/nvidia

sudo apt-get update

sudo apt-get install nvidia-349

but every time I try to boot up ubuntu normally with the GPU installed I'm left with a black screen. I've been managing to boot up ubuntu using recovery mode, but I'm looking for a more permanent fix. Does anyone know what I'm doing wrong or what I can try?

1

Try to install an nvidia driver from the official repos (instead of the ppa), for example using the Additional Drivers application, while your Nvidia card is not connected.

If that doesn't work, and assuming that your CPU has a built-in GPU, I suggest you remove all driver-related ppas and nvidia drivers first. Add the following lines to a new file, for example disablenouveau.conf, in /etc/modprobe.d/:

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

save, and then run

sudo update-initramfs -u

Also add nouveau.modeset=0 to your /etc/default/grub in the kernel parameters line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

and run sudo update-grub. You could also do this directly in the grub boot screen if you need to, as explained in How do I add a kernel boot parameter?.

Shutdown, re-install your graphics card and then boot the machine. This time, the system should start using default Intel/radeon/amdgpu drivers depending on what CPU you have. Now install the latest nvidia driver available in the Additional Drivers dialog. Such a process had fixed my issue with an Intel Core i7 Haswell and Nvidia GTX 860M.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.