1

Greeting's, I've tried to install windows 8.1 + ubuntu 15.04 thrice now. But both the time's i'm left with a peculiar problem. I have UEFI and Secureboot enabled. In the UEFI there is no option to disable fastboot, however I have disabled fastboot from windows power options.

I am installing windows 8.1 x64 first. I create a partition for windows and 1 for data. I let the installation complete and reboot using windows. Post first boot, i do another restart without making any changes to the system. Post second login - I selected advance option under update and recovery menu to boot from CD/DVD.

Once I've booted into Ubuntu DVD (as mentioned earlier, I do this through windows options and not by UEFI to BIOS and enabling CD/DVD option) I have non-formatted space on the HDD on which I install Ubuntu. I follow the graphic install. I select install ubuntu besides windows installer. Only custom option I enable is encrypting my home folder. Installation completes error free.

However post installation when I reboot and select windows from ubuntu's bootloader (GNU GRUB), it gives me an error about missing image and hence is unable to boot into windows.

Here is the real mystery, when I change boot options from UEFI settings to include windows bootloader above Ubuntu. Windows boots perfectly! and same way if i change to Ubuntu - even it loads perfectly!

Here is bit of the text from the entire error:

/Endentire File Path: ACPI (file path to a efi image)

Error: cannot load image

Here is an upload of the image - http://s27.postimg.org/hu4pyksf7/Ubuntu_Dual_Boot.jpg

Thank you for all the help till now guys! Here is the URL to boot-repair report: paste.ubuntu.com/11734144

Any idea WHY!

PS: I've checked disc for defects and even tried installing once with a USB stick created using pendrive linux.

  • Please post a photo/screenshot of the entire message that you get. – LiveWireBT Jun 16 '15 at 14:39
  • I can't upload image since my reputation isn't 10. – Parth Maniar Jun 17 '15 at 15:50
  • HHere is an upload of the image - s27.postimg.org/hu4pyksf7/Ubuntu_Dual_Boot.jpg – Parth Maniar Jun 17 '15 at 15:57
  • bugs.launchpad.net/ubuntu/+source/grub2/+bug/1091464 Grub does not boot Windows from grub menu when secure boot is on. – oldfred Jun 17 '15 at 16:57
  • It sounds an awful lot like this bug. There are several workarounds described in the comments, particularly #11, #31, #48, and #58. Note that things have changed a bit since I wrote #11; installing rEFInd from Ubuntu should set things up pretty much automatically. If you think that you're seeing this bug, be sure to click the link to say it affects you, and add a comment with any further information and experiences. (Your make and model of computer, any results you see that aren't already noted, etc.) – Rod Smith Jun 17 '15 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.