0

I already run trusty containers on my precise host. I have no issues.

I'm trying to run a vivid container on the same host. The container work, but there is no network. The container doesn't get any IP from DHCP.

Doesn't work better with static ip configuration. Even with static ip configuration, ifconfig doesn't return the configured IP for the eth0 interface (there is no "inet addr" line).

I tried the ubuntu (debootstrap) and ubuntu-cloud template. Same thing for both.

0

This might work. I had a similar problem: Fairly fresh and vanilla Ubuntu Wily (15.10) installation as host, and a newly created ubuntu lxc guest. Attached to the guest, and had no network connection. What worked for me was to do a

systemctl status -l lxc-net.service

on the host. Restarted the lxc guest, and the guest now got an IP address and a working network connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.