2

Whenever I click a download link in Firefox (Ffox 38, on Ubuntu 12.04LTS) such as a PDF, I get

screenshot 1

And there's nothing more sensible than GVim in the Open With menu.

When I look in about:preferences, I see

screenshot 2

Which seems to imply it's aware of a document viewer application, but then it's not giving me that option when it opens a PDF...?

I've used PDF here as an example, it's the same with other formats, e.g. it also offers to open tar files with Gvim...

How can I get Firefox 38 to correctly populate the Open with drop-down?

(nb. I'm aware that this has been asked before but those solutions only work for earlier versions of Firefox, so are irrelevant.)


EDIT: To be clear, my desktop system (Gnome Shell) does not have a problem opening files; it's just Firefox.

e.g.

$ xdg-mime query default application/pdf
evince.desktop
  • Try reset firefox to default settings, helped in some cases (different from your problem). I was lazy exporting bookmarks etc. but it helped. OR try creating new profile (which is very unlikely to help, but...) – RiddleMeThis Jun 16 '15 at 15:20
1

By using " xdg-mime " you should be able to change the default application from browsers. Please look at this link for more info.

EDIT: I wrongly pasted some comments here (Thanks artfulrobot for pointing that). Removed them now. Please look at the link mentioned above for changing the application preference.

  • 1
    Thanks. Specifically for me, inspecting ~/.local/share/applications/mimeapps.list showed that under application/octet-stream I had gvim and totem (?!) listed. As that mimetype is going to match all binary data it was taking over, unless there was a more specific match. Deleting that line from that file and restarting Firefox fixed the issue. – artfulrobot Jun 17 '15 at 8:56
1

Delete or rename your mimeTypes.rdf file, then restart Firefox. The mimeTypes.rdf file will be located somewhere in the ~/.mozilla directory.

  • Thanks for suggestion. I tried that (find ~/.mozilla -name mimeTypes.rdf -delete) but it didn't solve the problem :-( – artfulrobot Jun 17 '15 at 8:21
  • Actually, it's fixed it for PDFs, but not other files (e.g. .tgz) - still wants to open these with Gvim! – artfulrobot Jun 17 '15 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.