1

I'm a relative newbie. Ive done a bit of systems editing but only by copying scripts and seeing if they work - ie trial and error

I've created a ext4 partition. Gparted confirms (mount point: /media sda2, /mnt/sda2) (label: disk2) and says it is mounted but when I open it up and try to open a folder in it, I get an msg saying I dont not have permissions to view contents.

When ubuntu 14.04 starts up its says disk not ready or not present so I press s for skip

I want to have full access to the disk and its contents - can you help pls? if you start writing scripts, pls give examples and explain what each parameter means.

Thank you for your consideration.

/|\ paul c burr

ubpaul@ubpaul-NC10:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=079d07e4-d4c2-4c81-81dd-454b870dd9bb /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=28e06dd5-f4e6-4e91-8d50-9f93b8863fbb /home/ubpaul/disk2 auto sw,x-gvfs-show,x-gvfs-name=Disk2 0 0
/dev/sda2 /mnt/sda2 auto nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2

Unable to access “Disk2”

Error mounting system-managed device /dev/sda2: Command-line `mount "/mnt/sda2"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

  • when you say you are opening the folder and get a permissions error, exactly how are you going about it? can you go into a terminal and issue the command: ls -ld /mnt/sda2 – user55570 Jun 16 '15 at 9:23
  • Hi thanks for the prompt reply. I used the following command and now I can access the disk/partition and add folders files to it - which is a real breaktrhu for me!!! sudo chown -R $USER:$USER /mnt/sda2 BUT... I'm still getting two error msgs on startup saying (label) disk2 is not ready or present I press s for skip twice, the system boots and the partition Disk2 and its contents are still accessible. Can you help resolve the bootup problem pls? – Doctapaul Jun 16 '15 at 9:36
  • I would suggest try to comment or remove this line in /etc/fstab: UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2 – user55570 Jun 16 '15 at 10:16
  • ok - Ive turned the last line into a comment bit still got the startup prob – Doctapaul Jun 16 '15 at 10:27
  • Can you take a picture of the exact error or provide full details? – user55570 Jun 16 '15 at 10:29
0

You have lot of confusion in your question?

Did you remove the swap partition and make it ext4 as new partition?!

From your fstab:

swap was on /dev/sda2 during installation

And you say:

I've created a ext4 partition. Gparted confirms (mount point: /media sda2, /mnt/sda2) (label: disk2)

And how would you get two mounting points?!!

(mount point: /media/sda2, /mnt/sda2)

From your fstab

UUID=28e06dd5-f4e6-4e91-8d50-9f93b8863fbb /home/ubpaul/disk2 auto sw,x-gvfs-show,x-gvfs-name=Disk2 0 0

/dev/sda2 /mnt/sda2 auto nosuid,nodev,nofail,x-gvfs-show 0 0

UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2

Those are three entries full of mess.

What to do?

First Remove those three lines from your fstab

Now you have to review your configuration

Do you have swap partition? If yes add its entry to the fstab? (according to your fstab you have a swap on /dev/sda2)

Now be sure you create correctly a new partition and format it with ext4, and be sure not to replace swap if you want it already.

Now add the entry of your newly created partition.(note its name from gparted). You can add Entries in fstab either in name such as /dev/sdX or UUID, you can get the UUID running command:

sudo blkid

Also be sure to have one entry in fstab for every partition and with only one mounting point.

The correct syntax to add to fstab:

UUIUUID  /mounting-point ext4   defaults    0   0
  • Thanks - I think I;ve understood what youve said. Im getting help from another user. I not savvy enough to follow two threads at once but will get back to you - am very grateful – Doctapaul Jun 16 '15 at 11:17
  • I dont want a swap partition. I dont think I know what it is ??? I'll follow your format - thanks! – Doctapaul Jun 16 '15 at 11:23
  • @Doctapaul you are welcome and glad for you – Maythux Jun 17 '15 at 5:50
  • @Doctapaul Please take a look askubuntu.com/tour – Maythux Jun 17 '15 at 5:51
1

Many many thanks for all the input - Im truly grateful.

I've managed to resolve all the issues about accessing and mounting "Disk2" etc

I edited fstab thanks to Maythux and commented out the offending lines. Special thanks to user5570 for your patience with my ignorance.

/|\ paul

  • No worries. Glad to help. – user55570 Jun 16 '15 at 22:04
0

Its good that you found the solution to the permission issue.

About the startup issue, try running cat /etc/fstab to inspect your mount settings.

If you are mounting removable media in your /etc/fstab, you can comment that item in the fstab file.

Try to comment out this line in the /etc/fstab

UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2
  • perhaps best if you added the result by editing your original post. It will be easier to read the result that way. And then you can quote or mark the result as code. – user55570 Jun 16 '15 at 10:03
  • Hi, the first part refers to how it was originally setup. The last line was something I added from another forum - but I dont know if its affecting the situation or not - ta again! # swap was on /dev/sda2 during installation UUID=28e06dd5-f4e6-4e91-8d50-9f93b8863fbb /home/ubpaul/disk2 auto sw,x-gvfs-show,x-gvfs-name=Disk2 0 0 /dev/sda2 /mnt/sda2 auto nosuid,nodev,nofail,x-gvfs-show 0 0 UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2 – Doctapaul Jun 16 '15 at 10:04
  • sorry pilot6 and user55570 - I dont understand – Doctapaul Jun 16 '15 at 10:06
  • please paste the command output into your original post by performing "Edit". It will be easier to read that way. – user55570 Jun 16 '15 at 10:08
  • I dont understand how to inspect my mount settings - sorry for being unlearned, – Doctapaul Jun 16 '15 at 10:08
-2

A normal user can not have full access to an ext4 partition, unless you have became root with sudo command.

I guess that you tried to open lost+found folder. This one is a possible duplicate: link. It is somthing like "System Volume Information" in Windows.

You should try to create a directory. It should work with the default mount options.

  • Hi - thank you too for a prompt reply. I've now managed to gain permission to access Disk2 and update files/folders etc. I still have the startup problem - highlighted above. many many thanks – Doctapaul Jun 16 '15 at 9:41
  • I guess that you should remove this line: UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 defaults 0 2 and change /dev/sda2 line to this: /dev/sda2 /media/sda2 ext4 defaults 0 2 – szkj Jun 16 '15 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.