0

I'm unable to update my system Ubuntu 14.04 as software updater isn't running. Also I'm unable to run Ubuntu software center. All these problems arose after I tried to do partial upgrade of my system. I was as such updating my system but it messaged that some applications can be updated only after I do partial upgrade. I clicked on 'partial upgrade' option but it didn't happen successfully. A message was displayed

upgradation message

After that I'm unable to run software updater, Ubuntu software center etc.

EDIT#1

This edit is the output of the commands I ran as mentioned in the answer by IcyIcyIce

ravi@ravi-Aspire-5315:~$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade || sudo apt-get -f install
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://security.ubuntu.com utopic-security InRelease                       
Ign http://extras.ubuntu.com utopic InRelease                                  
Get:1 http://ppa.launchpad.net trusty Release.gpg [316 B]                      
Hit http://extras.ubuntu.com utopic Release.gpg                      
Get:2 http://ppa.launchpad.net trusty Release [14.0 kB]              
Get:3 http://security.ubuntu.com utopic-security Release.gpg [933 B]           
Hit http://extras.ubuntu.com utopic Release                                    
Ign http://in.archive.ubuntu.com utopic InRelease                              
Get:4 http://ppa.launchpad.net trusty/main i386 Packages [853 B]               
Get:5 http://security.ubuntu.com utopic-security Release [63.5 kB]             
Ign http://in.archive.ubuntu.com utopic-updates InRelease                      
Ign http://in.archive.ubuntu.com utopic-backports InRelease                    
Hit http://in.archive.ubuntu.com utopic Release.gpg                            
Ign http://ppa.launchpad.net trusty/main Translation-en_IN                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Get:6 http://security.ubuntu.com utopic-security/main Sources [58.9 kB]        
Hit http://extras.ubuntu.com utopic/main Sources                               
Hit http://extras.ubuntu.com utopic/main i386 Packages                         
Get:7 http://security.ubuntu.com utopic-security/restricted Sources [2,107 B]  
Get:8 http://security.ubuntu.com utopic-security/universe Sources [14.6 kB]  
Ign http://extras.ubuntu.com utopic/main Translation-en_IN                     
Ign http://extras.ubuntu.com utopic/main Translation-en                        
Get:9 http://security.ubuntu.com utopic-security/multiverse Sources [2,390 B]  
Get:10 http://in.archive.ubuntu.com utopic-updates Release.gpg [933 B]         
Get:11 http://security.ubuntu.com utopic-security/main i386 Packages [197 kB]  
Err http://in.archive.ubuntu.com utopic-backports Release.gpg                  
  Connection failed [IP: 91.189.91.15 80]
Get:12 http://security.ubuntu.com utopic-security/restricted i386 Packages [8,438 B]
Get:13 http://security.ubuntu.com utopic-security/universe i386 Packages [76.1 kB]
Get:14 http://security.ubuntu.com utopic-security/multiverse i386 Packages [4,502 B]
Get:15 http://security.ubuntu.com utopic-security/main Translation-en [93.0 kB]
Hit http://security.ubuntu.com utopic-security/multiverse Translation-en       
Hit http://security.ubuntu.com utopic-security/restricted Translation-en       
Hit http://security.ubuntu.com utopic-security/universe Translation-en         
Hit http://in.archive.ubuntu.com utopic Release                                
Get:16 http://in.archive.ubuntu.com utopic-updates Release [63.5 kB]
Hit http://in.archive.ubuntu.com utopic/main Sources                           
Hit http://in.archive.ubuntu.com utopic/restricted Sources                     
Hit http://in.archive.ubuntu.com utopic/universe Sources                       
Hit http://in.archive.ubuntu.com utopic/multiverse Sources                     
Hit http://in.archive.ubuntu.com utopic/main i386 Packages                     
Hit http://in.archive.ubuntu.com utopic/restricted i386 Packages               
Hit http://in.archive.ubuntu.com utopic/universe i386 Packages                 
Hit http://in.archive.ubuntu.com utopic/multiverse i386 Packages               
Hit http://in.archive.ubuntu.com utopic/main Translation-en                    
Hit http://in.archive.ubuntu.com utopic/multiverse Translation-en              
Hit http://in.archive.ubuntu.com utopic/restricted Translation-en              
Hit http://in.archive.ubuntu.com utopic/universe Translation-en                
Get:17 http://in.archive.ubuntu.com utopic-updates/main Sources [101 kB]       
Get:18 http://in.archive.ubuntu.com utopic-updates/restricted Sources [3,033 B]
Get:19 http://in.archive.ubuntu.com utopic-updates/universe Sources [28.6 kB]  
Get:20 http://in.archive.ubuntu.com utopic-updates/multiverse Sources [2,390 B]
Get:21 http://in.archive.ubuntu.com utopic-updates/main i386 Packages [282 kB] 
Get:22 http://in.archive.ubuntu.com utopic-updates/restricted i386 Packages [11.0 kB]
Get:23 http://in.archive.ubuntu.com utopic-updates/universe i386 Packages [110 kB]
Get:24 http://in.archive.ubuntu.com utopic-updates/multiverse i386 Packages [4,502 B]
Get:25 http://in.archive.ubuntu.com utopic-updates/main Translation-en [131 kB]
Hit http://in.archive.ubuntu.com utopic-updates/multiverse Translation-en      
Hit http://in.archive.ubuntu.com utopic-updates/restricted Translation-en      
Hit http://in.archive.ubuntu.com utopic-updates/universe Translation-en        
Fetched 1,274 kB in 5min 0s (4,247 B/s)                                        
Reading package lists... Done
W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/utopic-backports/Release.gpg  Connection failed [IP: 91.189.91.15 80]

W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package libfdk-aac0 needs to be reinstalled, but I can't find an archive for it.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package libfdk-aac0 needs to be reinstalled, but I can't find an archive for it.

I ran the above commands twice because 1st time it failed to fetch data. Now also the issue isn't resolved as I'm still unable to open the applications.

EDIT#2

This edit is the output of the commands as mentioned in the comment by IcyIcyIce in his own answer.

ravi@ravi-Aspire-5315:~$ apt-cache rdepends libfdk-aac0
libfdk-aac0
Reverse Depends:
  libfdkaac-ocaml
  libfdk-aac0-dbg
  libfdk-aac-dev
  aac-enc

@IcyIcyIce Could you make out something what the issue is & how I can proceed now?

migrated from unix.stackexchange.com Jun 16 '15 at 5:06

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

1

Try running the commands sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade || sudo apt-get -f install. If something went wrong, updating the repos, trying to update and if that fails, tries to fix corruptions.

Hope it helps :)

  • please look at my edit in the Q. It didn't work. – Ravi Jun 16 '15 at 7:13
  • you could check what depends from that package by running apt-cache rdepends libfdk-aac0. Maybe it could tell us something... – IcyIcyIce Jun 16 '15 at 7:22
  • I've shown the output of the command in my Q as EDIT#2. Can you make out something? – Ravi Jun 16 '15 at 7:49
  • well now I'm lost a bit. I'd definitely try sudo apt-get --fix-missing install or maybe it's without the install... anyways if you get an error saying the command is wrong just type without install. But from the previous post it seems like you can't contact a repo and that's why you can't download the package. Maybe you could try going to software sources and somewhere there you can choose another server to download from. But in this moment I wish someone else looked at this because I'm out of ideas... Hope you can figure it out somehow, if I get an idea I will definitely post it here :) – IcyIcyIce Jun 16 '15 at 7:54
  • Please look at the screen shot I added now of the messsage I got while upgrading. I think you can get a clue as what I should do now. Is that the issue? How to re-enable them now? – Ravi Jun 16 '15 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.