1

I'm trying to configure a Squid3 proxy server so that it doesn't log the requests made by authentificated users. I've tried the following config (squid.conf):

acl Users proxy_auth REQUIRED
log_access deny Users
# I've tried with and without this line, but without success:
log_access allow all

When I do that, absolutely nothing get logged in the access.log and no error is outputted to the cache.log. The same acl (Users) is used with http_access without problem.

When this config is disabled and I perform the same tests, I can see both types of requests (with a username and with a "-") in the access.log (with the "squid" format).

Using another acl (like http_status 200) works as expected.

Isn't it supposed to work ? If not, is there any other way I can manage to do that ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.