1

The system is still behaving exactly the same, and I have not received any further direction on how to fix it. Is there another piece of information I need to provide?

Update: No response from the gentleman who was helping me, I got tired of waiting and just did a complete wipe, repartition, and reinstall.

Installed the latest nvidia driver through the additional drivers application, but still have the same behaviour - underscanning saved to xorg.conf will not be used at reboot because xorg.conf disappears at reboot. Google Chrome is still launching in what looks like 640 X 480 mode (but nothing else is), the screen is extended past the border of the screen to the right and down, and the mouse pointer/cursor/arrow is still using a hotspot that is 35 pixels down and to the right of the actual arrow tip. The screen goes back to normal after I re-set the underscanning on the Nvidia control panel, but that change (saved to xorg.conf) will go away at every reboot. That is consistent with the bug report here. I cannot believe that bug report is just wrong, but maybe I just don't understand the issues I am having.

Current dkms status says:

bbswitch, 0.7, 3.13.0-55-generic, x86_64: installed
nvidia-331, 331.113, 3.13.0-55-generic, x86_64: installed
nvidia-331-uvm, 331.113, 3.13.0-55-generic, x86_64: installed

After the major system error resulting from using the latest kernel, I am hesitant to try it again.

Any other suggestions before I try that again?


I followed the suggested solution below, now all I get is a black screen, and no further instructions from the gentleman who was helping me. Does anyone else with experience on this issue have any idea what the next step is?

Ubuntu 14.04, Nvidia GeForce GT 440.

64-bit system.

the 'duplicate of' link is not the same... That solution has an answer that says to use 'sudo apt-get install nvidia-304 nvidia-304-updates', but one of the highest upvoted answers says to NEVER DO THAT. I've also tried that, and I get daily updates that report System Problems with that driver, then sent to a bug report that is 18 months old, and is still receiving 'not fixed' reports as recently as this morning.

dkms status
bbswitch, 0.7, 3.13.0-24-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-43-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-44-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-45-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-46-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-48-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-49-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-51-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-52-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-53-generic, x86_64: installed
bbswitch, 0.7, 3.13.0-54-generic, x86_64: installed
nvidia-331, 331.113, 3.13.0-45-generic, x86_64: installed
nvidia-331-uvm, 331.113, 3.13.0-45-generic, x86_64: installed
virtualbox, 4.3.10, 3.13.0-45-generic, x86_64: installed
virtualbox, 4.3.10, 3.13.0-53-generic, x86_64: installed
virtualbox, 4.3.10, 3.13.0-54-generic, x86_64: installed
  • possible duplicate of Ubuntu 14.04 install NVIDIA driver – mikewhatever Jun 15 '15 at 19:23
  • No, not a duplicate. oops, edit... hitting enter automatically saves and sends! That solution has an answer that says to use 'sudo apt-get install nvidia-304 nvidia-304-updates', but one of the highest upvoted answers says to NEVER DO THAT. I've also tried that, and I get daily updates that report System Problems with that driver, then sent to a bug report that is 18 months old, and is still receiving 'not fixed' reports as recently as this morning. – David Webb Jun 15 '15 at 19:26
  • Please add output of dkms status to your question. – Pilot6 Jun 15 '15 at 19:37
  • Perhaps this one would have been a better choice. Is there a reason you won't let the Drivers Utility do its job? – mikewhatever Jun 15 '15 at 19:43
  • I will do that in a few hours when I get home. I had tried that about a month ago when I first started trying to use linux, and that led to a different bug report that said the culprit was xorg.conf being deleted by some other app at boot, but that's been a month ago so I can't remember exactly. Regardless, I will post the output this evening. – David Webb Jun 15 '15 at 19:45
1

I would suggest upgrading kernel to 3.19 and installing 331 driver. Run

sudo apt-get install linux-generic-lts-vivid

reboot

sudo apt-get install --reinstall nvidia-331

reboot.

  • Wow. I got no fewer than a dozen System Program Problems, and a LOT of these: Error! Bad return status for module build on kernel: 3.19.0-20-generic (x86_64) The system is still collecting information for the reports, but I will reboot and hope for the best, and report the outcome here. – David Webb Jun 15 '15 at 21:55
  • It is something wrong in dkms config or somewhere else. It will be much easier to re-install the system. It is not the problem of drivers. Last try will be 346 driver with this 3.19 kernel. It seems that you broke something there. I use Nvidia drivers on 14.04 without any problems. They just do not install to your system. – Pilot6 Jun 15 '15 at 22:00
  • Well after it got done with that, it asked to reboot. It had been sitting at the purple "Ubuntu 14.04" screen for at least 5 minutes with 1 white dot and 3 orange ones. When it finally shuts down and reboots I will run the next line and see what it does. What did I break and how? And what about this being related to a big that is 18 months old? Could my system have that bug too? – David Webb Jun 15 '15 at 22:08
  • I do not know what did you break or how, but drivers just do not install. And they do install for me and most of other people. I use them for more than 18 month with no problem. Just re-install and the problem will be gone. – Pilot6 Jun 15 '15 at 22:10
  • 1
    mount -o remount,rw / lets me enter commands now. Trying to reinstall the driver now. But since the kernel you suggested caused so menu problems, should I really use that one? Is the read only because I took too long? – David Webb Jun 15 '15 at 23:08
-1

Try this link: http://www.geforce.com/drivers/results/49072. This is the GeForce driver for 32 bit systems. You did not specify what you had, so if yours is 64 bit then http://www.geforce.com/drivers/results/86390 Should do the trick.

  • Thank you, I don't know if I want to try a driver from yet another source - most of the replies I am seeing today on my issue, as well as similar ones, make mention of NOT using anything other than the Drivers Utility. As I understand it, linux is about trying things out and reporting problems - as was explained to me, if a driver from somewhere other than the standard ubuntu driver utility fails to work, it does not point to the OS as a problem. I'd rather do it the right way, and if it helps solve an 18-month old bug, then great. – David Webb Jun 15 '15 at 20:55
  • If the Ubuntu driver utility doesn't work, then this is the way to go. It is the genuine driver from Nvidia GeForce. – Daniel Jun 16 '15 at 16:11
  • I appreciate your assistance; last night I received some steps to follow that led me away from the 'additional drivers' screen in ubuntu; I ended up having to wipe and reinstall. The one through there does not work, and nothing else I've tried has made a difference. Does the ubuntu 'additional driver' screen not use the genuine driver? Which is the one at the heart of all of the duplicate bug reports? – David Webb Jun 16 '15 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.