9

I am aware that there are many similar questions in this site, but none of the seems to solve my problem.

I've been trying to install ubuntu 14.04 alongside a preinstalled Windows 8.1 in a toshiba z30-b for days and I have currently the following situation:

  • Both OS are installed
  • Windows 8.1 boots directly when I select boot mode "UEFI mode" in the UEFI settings
  • Ubuntu 14.04 boots directly when I select boot mode "CMS mode"

I try to run boot-repair in ubuntu to solve this issue, but it says:

"The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will activate the function. For example, use a live-USB of Boot-Repair-Disk-64bit, after making sure your BIOS is set up to boot USB in EFI mode."

The problem is that I have found no way to boot ubuntu in "UEFI mode", either from USB or from the HDD (it seems that Toshiba laptops can't load USB in UEFI mode)

Other details are:

  • Security mode is disabled
  • Fast boot is disabled as well
  • All the details of the output of boot-repair here

Do you have any hints?

**************** EDIT *****************

Problem solved. I can boot both OS in UEFI mode. The problem was that the way I had created the USB was not the correct one. I followed the instructions in here, and that solved the problem (I had tried this earlier without GPT partitioning and it didn't work.

  • May be better to turn secure boot setting off, but should not be required. You should have two boot options for Ubuntu live installer if it is the 64 bit version. It should show UEFI - name/label of flash drive. The other option for BIOS boot will be just the name/label of flash drive. Shows install with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen help.ubuntu.com/community/UEFI – oldfred Jun 15 '15 at 17:56
1

It's not clear if you've installed Ubuntu in BIOS/CSM/legacy mode or if you're saying you haven't yet installed it but that you can boot the installer in BIOS mode.

If you want to boot the installer, either to install directly or to run Boot Repair, you must find your EFI's built-in boot manager. In most cases, this can be accessed by hitting a function key early in the boot process, but which one is completely non-standardized. (Some computers also use some other key, like Esc.) When it comes up, it will usually have two options for external media, one of which includes the string "UEFI" and the other of which does not. Select the "UEFI" option to boot in that mode and the other one to boot in BIOS/CSM/legacy mode.

In some cases, you may need to enter the firmware setup utility to disable its "fast start" feature (or words to that effect; again there's no standardization) in order for the boot manager to become available.

Also, note that only the 64-bit version of Ubuntu has an EFI boot loader. The 32-bit (x86) version lacks an EFI boot loader and so is not bootable in EFI mode unless you add an EFI boot loader of your own -- and installing the 32-bit Ubuntu on a system with a 64-bit EFI adds another layer of trickiness, so I do not recommend going that route.

Secure Boot should not be an issue, but sometimes it is, so disabling Secure Boot may be worth doing if you try other things and still can't get it to work.

As a general rule, you should not perform a BIOS/CSM/legacy-mode install of Ubuntu on a computer that already has Windows booting in EFI/UEFI mode. If you've already installed in this way, you pretty much must get the Ubuntu installer booted again in EFI mode, either to run Boot Repair or to re-install Ubuntu. The other option is to install an EFI boot loader in some other way. For instance, you could use the USB flash drive version of my rEFInd boot manager to boot Ubuntu in EFI mode, then either switch from the BIOS-mode GRUB (grub-pc) to EFI-mode GRUB (grub-efi) or install rEFInd to the hard disk via the Debian package or PPA.

  • Thanks a lot for your answer. I have formated again the computer to its initial status: Windows 8.1 booting with an EAFI boot loader. The problem is – Unai Jun 16 '15 at 12:54
  • Sorry I tried to edit the comment but I was late. The main problem is that I can't boot the USB in UEFI mode. When I try to boot the USB, the "Toshiba" screen appears and the laptop does not react to anything (for example pressing the function keys). But when I turn to mode CSM the USB boots perfectly. I have checked that the usb has a 64-bit version of Ubuntu 14.04 . Do you know what can be creating this behaviour? Maybe the method of crating the bootable USB is not ok. Can you give an url with the best method to create the USB? Regards – Unai Jun 16 '15 at 13:06
  • 1
    Some tools for creating bootable USB drives omit the EFI boot files. I've successfully used the latest versions of Rufus, UNetbootin, Startup Disk Creator, and dd (a standard part of Ubuntu). That said, there can also be system-specific quirks, so you may need to try another tool -- one that works for me and my computers might not work for you and your computer. – Rod Smith Jun 17 '15 at 13:12
0

I noticed in October 2014 Toshiba was providing BIOS updates that disabled EFI booting for any other OS other than the preinstalled Microsoft OS (8.1). I have a Toshiba Satellite_S55-A5188. It shipped with BIOS v1.4 and I updated to the latest (at the time) to V1.7. With these two versions I could only dual-boot with the CMS (GRUB2) BIOS setting. When Toshiba posted BIOS v1.90 I applied this update. This was a major mistake. Embedded within this BIOS was a dynamic variable reset feature. When the Linux install applied the EFI SHIM path required for a secure boot, the BIOS noticed the change and rewrote the default Microsoft path over the Linux setting. This means my Toshiba will never run any OS other than a Microsoft signed EFI based OS. I spent weeks investigating this. On many other Linux sites I found the above to be true for Toshiba laptops in general that were shipped both to Australia and the EU. All the people on blogs I read or communicated with were design engineers. The Toshiba engineers in these blogs thanked everyone for their input, but Toshiba would not support other OS on its current line of Laptops.

Your Toshiba Z30-B has many model variations and with a discrete model # for each. Upon checking a few Z30-B's, the BIO versions are totally different for each sub model. Check your Z30-B's Model number on the back label and also your BIOS version. On the Toshiba Support website, enter the full model number and go to the software update list. Select the BIOS check box and a list of all the BIOS versions for that laptop will be listed. If the current BIOS installed on you laptop is old enough you may be able to just dual-boot with the CMS setting. I do not recommend updating your BIOS to any newer version. It may (like in my case) block the use of CMS for dual boot.

  • 1
    Welcome to Ask Ubuntu! Say, would you mind fixing up the formatting on this post a bit? This is hard to read. A few line breaks to begin with would do a lot of good. – anonymous2 Mar 9 '17 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.