-1

I am new to Ubuntu and am using a remote server with Ubuntu 14.04 installed on it (headless). I use putty (on a Windows laptop) to connect to it - ssh with private and public keys. I have also set up ssh tunnelling for socks (dynamic, port xxxx). Saved the session as EmmaWatson. Done.

Fired up the browsers (both Chrome and Firefox) on my Windows laptop, installed the SwitchySwarp extension in Chrome and the FoxyProxy add-on in Firefox. I filled in the details (socks5, localhost - port xxx), enabled the proxy.

Everything worked fine: for a week I was happily using my proxy to surf the Internet, but all this changed yesterday. Now, for whatever reason, every time I enable the proxy - web pages load fine initially, then the connection hangs, pages stop loading and at the same time the Putty Session (EmmaWatson) also freezes/hangs!!

When I disable the proxy, it unfreezes and putty terminal becomes responsive again.

I assumed Putty was acting up. So I installed Connectbot on Android, forwarded the port (tunnel), fired up the Firefox browser on Android, made changes to about:config, and it worked! But, it too froze soon after (mere minutes). The terminal (connectbot) became unresponsive and I had to close it.

Next, I came back to Putty. This time I created another Putty session 'Hermoine' without the tunnel settings. Loaded the first session (EmmaWatson) - enabled proxy in browser and let it freeze. Then I loaded the second session (Hermoine) and it was snappy! Closed Hermoine, added the same tunnel settings as EmmaWatson and re-loaded the new Hermoine. It was snappy. But, EmmaWatson remained frozen. :(

  • tl;dr - everytime I use the socks proxy, everything (the terminal) freezes!

Additional info:

  • using Windows 8.1 client, android 5.1.1
  • ssh - compression - enabled (Is this relevant?)
  • socks5
  • all other programs are working fine
  • deluged. The system doesn't hang. Only the terminal emulators hang.
1

I think I solved my problem. The culprit seems to be MTU settings. My home connection is PPPoE with max MTU set to 1460. So, I changed MTU settings on my Ubuntu Server to 1460 and things improved, there was still a little lag though, apparently due to SSH overhead. I dialed it down to 1432. Things are normal now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.