2

I am using Ubuntu 14.04LTS and I haven't really had much luck using LibreOffice. I am currently using LibreOffice v4.2.8.2 build ID: 420m0(build:2). I attempted to switch to Open Office and this hasn't fixed the problem either. I posted a video to youtube showing how slow LibreOffice is on a typical refresh:

https://youtu.be/_YnVnpvrWEA

I am running an Intel Q6600 with 8GB of ram, with an ATi R7 260x video card. I also have 3 monitors attached to this card. I am using the Catalyst driver instead of the Radeon driver. I've tried disabling "Use hardware acceleration" to see if that might help, though to no avail.

I've stopped almost all user processes and this doesn't seem to help. Top indicates a load average of 0.26, 0.50, 0.69. When I minimize the window and restore it, I temporarily see the xfdesktop process jump to ~25% but drops quickly, however, kworker and migration processes goes to ~30% during the entire time that it takes to refresh the UI, and on completion go down to nothing.

2

BINGO! I think I just found a clue on this issue -- This should be reported to the LibreOffice developers and I'll try to figure out how to do that as well:

I noticed that if I logged-out of my account then re-logged back in, the problem would immediately go away (ie, menus operating normally). I was shocked to see this, as I've never seen it work correctly before on this computer. I also noticed that upon rebooting/auto-login of my account, if I IMMEDIATELY launched LibreOffice, it would also seem to operate normal. But eventually it would become slow (ie, after closing LibreOffice and then later re-opening it on a new document).

This seems to indicate that maybe another background process is interfering somehow, or perhaps the LibreOffice components are not starting up in the correct sequence??

A workaround I've found that seems to be working consistently is to just turn on the quickstarter feature. That causes the components to load immediately upon login and perhaps they get priority over whatever else may be interfering.

Tool-> Options-> LibreOffice-> Memory-> [X] Enable systray Quickstarter

Hope this helps!

| improve this answer | |
  • My colleague noticed this same problem with LO 5.2 on ubuntu 14.04. He found out that once he disconnects his extra screens from his laptop, LO just flies. – Dark Star1 Aug 15 '17 at 7:33
  • Ubuntu 14.04.5 here, on a AMD dual core c-50 (1ghz) and 4GB ram.. same issue. Tried the Quickstarter tip, and did not work. I haven't tried rebooting yet, but I did try killing "soffice" and restarting. Tried with and without hw acceleration, disabling JRE, etc. No idea what's going on. – insaner Dec 19 '17 at 7:08
  • Rebooted, Quickstarter enabled, problem still occurs. – insaner Dec 20 '17 at 7:32
  • Rebooted again, quickstarter enabled, and now problem is gone.. *shrug*. Thanks!! +1 – insaner Dec 25 '17 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.