2

I have to justify why my question is different to the answer someone linked. Basically if you go to system > details > default apps, this sets the default app for ALL video file types as opposed to just an mp4 or whatever.

Can you please explain how to set a particular file extension or file type to open with a different default application. For example, I have just installed VLC player and I want all my video files to default to open with VLC when I click on them.

I've tried right clicking on a video file, selecting "open with" & clicking "other application". Then I highlighted the default video application from the menu and selected "forget association" so that VLC is the only option in the the in the "recommended application" list. When I double click on my video file it still opens with the default video player instead of VLC. So what can I do to fix it?

  • possible duplicate of How to set default program? – JoKeR Jun 15 '15 at 8:24
  • also askubuntu.com/questions/606858/… – JoKeR Jun 15 '15 at 8:25
  • @john smith if answers below have helped you to find solution to problem you should accept the answer that helped you the most. This will not only reward the author, but you will also contribute this forum and will provide guidance to other users who might have same/similar question. Cheers – Serine Jun 16 '15 at 6:51
  • I will test them tonight. I have tested 2- 3 of them so far and they didn't work. Will do some more digging tonight, – john smith Jun 16 '15 at 13:42
4

To do it command line like:

Check if totem is the default for your video:

cat /usr/share/applications/defaults.list | grep video

The output would be like(many other lines):

video/x-avi=totem.desktop

Append those lines to the file ~/.local/share/applications/mimeapps.list This contain the mimeapps with theri association

cat /usr/share/applications/defaults.list | grep video >> ~/.local/share/applications/mimeapps.list

Now open the file

gedit ~/.local/share/applications/mimeapps.list

and replace all occurence of totem with vlc (you can use the shortcut Ctrl+H)

save and exit. enjoy

source and more info

Note: If you want to make it available for all users in your system you should replace all occurrence of totem with vlc in the /usr/share/applications/defaults.list instead of ~/.local/share/applications/mimeapps.list.

To do it GUI like:

Rightclick any video file, choose properties. Choose Open With and there you can select VLC and the option set as default (bottom right).

enter image description here

This requires you to do that for every video type (mp4, mpg , mpeg, mov ....)...

Another perfect method is to use the option in Default applications.

go to "System Settings" "Details" "Default Applications"

CLick on the "down arrow" for "Video"

Select "VLC Media Player"

Then close window.

enter image description here

  • The first option didn't work, it doesn't show me the "default application" menu option. It only showed me the "recommended application" name instead. I will try the second method tonight when I test. – john smith Jun 16 '15 at 13:44
  • Thanks this works. The reason I couldn't get the first option to work is because I right clicked the file and went to open with. If you right click a file and choose properties then go to the open with tab, you get a very similar set of options which is what I was doing originally when I couldn't get it working. Thanks very much! – john smith Jun 16 '15 at 22:59
  • @johnsmith You are welcome friend – Maythux Jun 17 '15 at 5:48
3

If you are running standard ubuntu the easiest way to set some default application is through settings. system settings -> Details -> Default Applications (menu on the left hand side)

The easiest way to find settings is to type in dash

3
  1. Right click on your video
  2. Go to properties
  3. Select open with
  4. Select your prefered application
  5. Click Set as default button
1

Right click the file in Nautilus, select properties from the context menu, click on the Open With tab at the top, and choose the application you desire. You are done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.