0

Trying to create a virtual machine using this downloaded 'kubuntu-14.04.1-desktopamd64.iso' virtual disk image. However when I go to 'Install Kubuntu'.

I get the following error:

    Installer Crashed

    Tracback (most recent call last):
    File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py",line 463,in
    <lambda>
     0, lambda:self.dbfilter.start(auto_process=True))
    File"/usr/lib/ubiquity/ubiquity/filteredcommand.py",line 103, in start 
     prep = self.prepare()
    File"/usr/lib/ubiquity/plugins/ubi-prepare.py",line 232, in prepare
     self.setup,sufficient_space()
    File "/usr/lib/ubiquity/plugins/ubi-prepare.py",line 244, in setup_sufficient_space
     self.ui.set_sufficient_space(self.big_enough(size))
    File "/usr/lib/ubiquity/plugins/ubi-prepare.py",line 251, in big_enough
     std=out subprocess.PIPE,universal_newlines=True)
    File "/usr/lib/python3.4/subprocess.py",line 848, in __init__
     restore_signals,start_new_session)
    File "/usr/lib/python3.4/subprocess.py",line 1384, in_execute_child
     restore_signals,start_new_session,preexec_fn)
    OSErrorL[Error 12] Cannot allocate memory


Computer specifications:

OS: Windows 7 Home Premium 
Manufacturer: Dell
Model:  Studio XPS 8100
Processor: Intel(R) Core(TM) i5 CPU  650 @ 3.20GHz 3.20 GHz 
Installed Memory: 6.00 GB
System Type: 64-bit operating system
  • Did you allocate too much memory to the VM? – Webtm Jun 14 '15 at 22:07
  • how do i know if i've allocated too much memory? i allocated 80GB, host machine has around 800GB free – pwhc Jun 14 '15 at 22:16
  • Memory is not storage. Are you saying you allocated 80GB of disk space, or 80GB of memory? I.E RAM or HDD – Webtm Jun 14 '15 at 22:19
  • standard 512 RAM; 80GB disk space – pwhc Jun 14 '15 at 22:30
1

From the error message, it seems to stem from "Cannot allocate memory." When creating the VM, did you leave the amount of RAM dedicated to the VM set at 512MB? 512 is listed as the minimum for Kubuntu, but 1024 would work much better.

There should be no issues running Kubuntu in VBox. I suspect your .iso is damaged. Re-download and try again (version 15 is out now also.) In VBox, make sure you pick Linux, then Ubuntu as the type of VM.

Edit: I just tried with lubuntu-15.04-desktop-i386.iso and VirtualBox 4.3.28, and received this lovely output. This was after the GUI installation finished and it went to reboot:

Lubuntu x32

Reset the VM and it appears to be working. This is strange because lubuntu 14.04 was tested just last month and there was not a single issue. Note, I enabled "PAE/NX" in the VM settings before starting it, gave it two CPU cores, and 2048 megabytes of RAM.

Just tested with Kubuntu 15.04 x32, with PAE/NX turned on, two CPU cores, 2048MB. Booted right up, installed everything including updates and extra features, worked fine. However, it too, "hung" during reboot (no output), and a reset got it working again. Ran the Muon update manager, installed a slew of new updates. So I do think either your downloaded .iso is corrupt, or in a rare case, virtualbox is misbehaving.

Working

Note that unless you're giving a VM more than 4GB of RAM (or using it to code 64-bit apps), there isn't much point to using a 64-bit guest OS. Try the 32-bit version instead.

| improve this answer | |
  • 1
    Both linux and debian 64-bit were chosen as the type of VM . I've tried 14.04 (previous version) and 14.04.02 (latest version) - both have the same installer trash result – pwhc Jun 14 '15 at 20:35
  • Im not sure what the original issue was, and it hasn't been resolved. However 'kubuntu-14.04.1-desktopamd64.iso' now works with PAE/NX turned on, two CPU cores, 2048MB of RAM and 64GB of disk space. P.S. I too tried 'lubuntu-15.04-desktop-i386.iso and 'VirtualBox 4.3.28' and got the same 'SQUASHFS error'. – pwhc Jun 15 '15 at 12:25
  • For completeness, I created another VM (Ubuntu 32-bit, 512MB RAM, 98GB disk and didn't touch any other settings) and tried again. It booted fine, installed fine, rebooted fine, works. It is much slower and sluggish than the first install, because this one only has 512MB RAM. So PAE/NX nor 512MB RAM are required for it to work. – rdtsc Jun 15 '15 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.