I have a PC running Ubuntu 11.04 with 2 nics. eth0 is internet and eth1 in Internal Lan. eth0 is connected to the internet talks and receives the correct DHCP addresses from ISP. I can from this computer ping the DNS servers at my ISP, I can ping www.google.com and any other sites so the DSN's are working fine. I have a dhcp server on the lan side that serves up the ip addresses to my computers connected to the internal lan. I have a firewall between the two nics (eth0 and eth1). This computer is also the gateway for my internal lan computers to access the internet.

What is more baffling is that any lan side computer (these are different flavours of Operating Systems i.e. ubuntu 10.04, Mac snow leopard, windows xp) all work fine, they can get to browse the internet using a range of browsers (firefox v3.6.22, safari, & ie) but here is the problem - the gateway computer can't browse the internet - this is the one that is running ubuntu 11.04, firefox 6.0.2. it also has a problem with even the ubuntu software centre which it can't download programs.

Help is needed and it would be greatly appreciated, I've tried the usual stuff that is recorded on the forums like ipv6 etc. But all my other computers go through this one and they have no problems - it must be something to do with ubuntu 11.04. very puzzling... please help. cheers JJ


Well, a good step is to start at the bottom and work up.

  1. Apparently you do have ip connectivity and routing because you can ping an external machine.

  2. Apparently you also have working DNS because you can resolve google.com to ping it.

  3. Can you open a tcp socket? Try telnet google.com 80 from the command line and see if you get 'connected' or not.

  4. Can you do http from the command line? How about wget -v http://google.com/robots.txt?

  5. If those all work, check a different graphical browser.

My guess is your firewall rules pass forwarded packets but block some essential packet to or from localhost.

  • Just tried telnet ggogle.com 80 – toonie Sep 30 '11 at 0:02
  • it returned trying and is still trying. sorry don't have curl and can't download the program... – toonie Sep 30 '11 at 0:05
  • all the other computers on the lan can go through the firewall via gateway without any problems – toonie Sep 30 '11 at 0:08
  • @toonie No need to use curl, updated answer so you can use wget, which is installed by default. – jrg Sep 30 '11 at 0:18
  • wget -v returned - resolving google.com..., ...105, ...106, connecting to google.com it's been like that for a few mins now. – toonie Sep 30 '11 at 0:24

It sounds like you have a problem with DNS(Domain Name System) on your computer. I've had a problem like that before where I could ping websites like you can but had problems with Internet browsers showing the websites and it ended up being a problem with the way my computer was working with DNS. I personally don't know too much about DNS but I'd suggest looking up in Google and see what you come up with and see if any of the fixes that pop up work for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.