2

I'm having trouble with my touchpad with Ubuntu 15.

When running it off the usb drive the touchpad didn't work already. I rebooted and went straight to the setup and there it worked no problem.

Then the touchpad worked for a while until it spontaneously didn't anymore (after a reboot). Googled a bit and found something about the touchpad indicator. It doesn't actually seem to work on Ubuntu 15. At least I see no indicator. Even so after installing that and rebooting the touchpad was recognized once again.

Then it worked for a while again until it spontaneously didn't anymore (after a reboot), which is now. Checked xinput and /proc/bus/input/devices and it's not even detected unfortunately.

Any idea what the problem might be and how it can be that it works for a bit and then Ubuntu decides to forget about it all of a sudden? It works just fine on Windows.

Here's some info:

cat /proc/bus/input/devices

N: Name="Sleep Button"
N: Name="Power Button"
N: Name="Lid Switch"
N: Name="Power Button"
N: Name="AT Translated Set 2 keyboard"
N: Name="HDA Intel PCH Mic"
N: Name="HDA Intel PCH Headphone"
N: Name="Video Bus"
N: Name="HDA Intel HDMI HDMI/DP,pcm=3"
N: Name="HDA Intel HDMI HDMI/DP,pcm=7"
N: Name="HDA Intel HDMI HDMI/DP,pcm=8"
N: Name="ELAN Touchscreen"
N: Name="MOSART Semi. 2.4G Keyboard Mouse"
N: Name="MOSART Semi. 2.4G Keyboard Mouse"
N: Name="PC Cam"

Note that the laptop does have a touchscreen and it works. The MOSART mouse is a bluetooth mouse I use to be able to point at things without having to touch the screen.

xinput --list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=10   [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse          id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ MOSART Semi. 2.4G Keyboard Mouse          id=12   [slave  keyboard (3)]
    ↳ PC Cam                                    id=14   [slave  keyboard (3)]

uname -a

Linux devtop 3.19.0-20-generic #20-Ubuntu SMP Fri May 29 10:10:47 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


dmesg | grep pnp
[    0.211331] pnp: PnP ACPI init
[    0.211600] pnp 00:02: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.218056] pnp 00:05: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.218106] pnp 00:06: Plug and Play ACPI device, IDs ETD0414 PNP0f03 (active)
[    0.219325] pnp: PnP ACPI: found 9 devices

Don't know what kind of laptop it is. It's some sort of custom-built one. I do know that the touchpad is from elantech, though.

  • Please edit your question and add output of dmesg | grep pnp terminal command. – Pilot6 Jun 14 '15 at 13:56
  • I updated the answer. – Pilot6 Jun 14 '15 at 14:37
5

The i8042.kbdreset=1 kernel boot parameter fixed my problem. To shamelessly copy @Pilot6's instructions:


Run sudo -H gedit /etc/default/grub

And add there to the line GRUB_CMDLINE_LINUX_DEFAULT= i8042.kbdreset=1.

It should look like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.kbdreset=1"

Then save the file and run

sudo update-grub

With this the touchpad will work after a reboot and will continue to do so after rebooting again.

| improve this answer | |
  • Worked like a charm on Ubuntu 16.1, thanks! – shan Nov 5 '16 at 22:17
  • Worked for me on a Gigabyte P37W v5 ! – Tryum Feb 15 '17 at 14:50
1

i8042.nomux=1 kernel boot parameter may help.

Run sudo -H gedit /etc/default/grub

And add there to the line GRUB_CMDLINE_LINUX_DEFAULT= i8042.nomux=1.

It should look like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux=1"

Then save the file and run

sudo update-grub

It may work after reboot.

| improve this answer | |
  • Mh, I just rebooted again after a couple of days when I would just let the laptop sleep and now the mouse is not working anymore again. :( Do you have any other ideas? – Machisuji Jun 21 '15 at 21:30
  • @Machisuji If kbdreset=1 solved it for you, then write your own answer and accept it. – Pilot6 Jul 4 '15 at 8:15
0

As far as I know, I have an Elantouchpad also on this Asus UX31E. The default drivers have been working great with it. There is a solution here for a Focaltech touchpad.

| improve this answer | |
  • 1
    OP has Elantech. And the Focaltech solution was made by me :-))) – Pilot6 Jun 14 '15 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.