8

So I am trying to get the Vino VNC Server to startup on boot, meaning I don't have to login to have the VNC Server start. I am on Ubuntu GNOME 15.04, and I have already added

/usr/lib/vino/vino-server

to 'Startup Applications'. However, the VNC Server still won't start as soon as I boot up. I have to login in order for the VNC Server to start. What should I do? Do I need to create a systemd unit file? If so, how do I do it?

Edit: This question is different from this becuase I need Vino Server to work, while that guide suggests x11vncserver.

3

create a systemd unit or service to run vino server at startup

  1. cd /etc/systemd/system/
    
  2. sudo vim vinostartup.service
    
  3. [Unit]
    Description = description about the service
    After = network.target
    [Service]
    ExecStart = /usr/lib/vino/vino-server
    [Install]
    WantedBy = multi-user.target
    
  4. Enable the service

    sudo systemctl enable vinostartup.service
    
  5. Verify it using below command vinostartup.service will be there

    ls multi-user.target.wants/
    
  6. If you don’t want to wait until next boot (it’s already enabled) we can start the service

    sudo systemctl start vinostartup.service
    
  • Thanks but doesn't work, unfortunately :( – Matt Mar 1 '18 at 17:19
2

Must have SSH enabled and root access to the server, then, SSH to it using your normal user account and edit the /etc/gdm3/custom.conf file making the following lines in [daemon] section look as this:

AutomaticLoginEnable=true
AutomaticLogin=yourusername

Save and reboot the server by running "sudo shutdown -r now". Once gdm restarts, it will automatically login as the specified user, and your vino-server process will then start, so you can VNC into the system again. Don’t forget to remove those auto-login lines from /etc/gdm3/custom.conf file when you’re done.

Edited from https://encodable.com/tech/blog/2009/03/02/How_To_Access_A_VNC_Remote_Desktop_After_The_Server_Reboots

-1

vino-server could not start with systemd successfully,it will look for a mir server and return a socket error on my ubuntu desktop.It looks like the gnome developers have recently added a systemd compile option to the project
The correct way to do this is to use the Startup Application in you desktop distro
Find the autostart program of yout distro from here archlinux autostarting page base on your own desktop enviroment

Here is the full instructions of configuring vino server

For example: I use an xfce desktop
Navigate to : Start->Applications Menu->Settings->Sessions and Startup->Application Autostart and find the 'Desktop Sharing' and enable it or you can just add /usr/lib/vino/vino-server to it

Before that you may have to config the vino server
I have no gnome settings pannel on my xfce desktop so i run

$ vino-preferences

from the terminal to config the connecting setting

And you may have to disable the encrytion to enable vnc clients to connect to you computer

$ gsettings set org.gnome.Vino require-encryption false

restart and DONE

  • Startup Application in a desktop won't start until you login though. The question asks how to start the server BEFORE login. – endolith Dec 10 '18 at 3:49
-2

I think you can go to Control Center, then Startup Application and add a new item with the command:

/usr/lib/vino/vino-server &
  • This doesn't happen until after you login – endolith Dec 10 '18 at 3:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.