0

The issues are listed in this link, but I'll relist/summarize here:

Ubuntu 15.04 is locking up on me, primarily when watching internet videos or listening to Slacker Radio. I have Ubuntu installed on a Gigabyte F2A88XM-D3H with an AMD A10-7870k, 8 GB ram (2x 4GB) and an Antec Green 380 PSU. Memtest reports no errors on 5 passes over 14 hours, but displays RAM as 7111 MB DDR2 (not DDR3, it's not a typo) when UEFI BIOS reports correctly 8192 MB DDR3, and Ubuntu displays 7020436K in "free" so I'm not sure that the RAM isn't the culprit. "sensors" reports 0°c or below freezing temps, but BIOS shows 57°c max for CPU when it is left for several minutes to find equilibrium so I don't think heat is a problem.

I've seen recommendations saying everything from flash being unstable to any one of my core components being faulty, and I'm really not sure where to go from here. Please assist.

Additionally as requested, output of lspci -k | egrep 'VGA|Display' -A2

andrew@mediacenter:~$ lspci -k | egrep 'VGA|Display' -A2
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] (rev d4)
Subsystem: Gigabyte Technology Co., Ltd Device d000
Kernel driver in use: radeon

I installed the fglrx proprietary driver and have rebooted. I have tested with Firefox, Chromium, and Google Chrome and they all still freeze up the computer. Using [alt]+[SysRq]+[R][E][I][S][U][B] works if I do it shortly after the freeze, but if I wait just a few seconds it does nothing.

lspci -k | egrep 'VGA|Display' -A2 now reports Kernel driver in use: fglrx_pci

Additionally, I have been running Ubuntu from the installation media (a 8 or 16 GB flash drive) for over 5 hours now with Google Chrome installed playing YouTube videos with no problem.

Sometime between the 5 hour mark and now (13 hours later) the LiveCD locked the screen and xorg crashed. However, the computer never locked up/hard froze.

Is it possible that some of the files are corrupted for the installation portion of the drive? I'm going to redownload 15.04, recreate the bootable flashdrive, and reinstall Ubuntu to see if that was the problem this whole time.

As it turns out, flash is likely not related. I was booted into the system running disk diagnostics (badblocks and disk utilities) having not started a web browser at all since boot, and I still got a freeze. I'm now believing that an update or hardware are causing the system failures and the web browser/flash is fine. I'm currently booted off the live "CD" (USB flash drive) and running badblocks on the hard drive.

Is there possibly a log of sorts that I can inspect that might help diagnose the crash?

  • Please edit your question and add output of lspci -k | egrep 'VGA|Display' -A2 terminal command. – Pilot6 Jun 14 '15 at 9:21
  • Looks like it might be related to the hdd as the moment badblocks finished and reported no errors, the system froze. The end of the disk was partitioned for swap the first time, which could explain why it's not freezing on the live CD except when I used badblocks on it. The second installation did not appear to partition a swap, but I'm unclear as I installed using UEFI compatibility. – Spaz Static Jun 17 '15 at 5:08
0

Have you updated your BIOS? ( http://www.gigabyte.com/products/product-page.aspx?pid=4714&dl=1&RWD=0#bios )

I just got the 7870K with the F2A88XM-WIFI and ran in to similar problems on 15.04. Then tried OpenSuse 13.2 which failed more gracefully. Then tried Windows 8.1 and still it crashed.

After updating the BIOS no crashes yet. fingers crossed

Note: your memory speed setting are reset after updating the BIOS.

  • Apart from the BIOS upgrade which is working it seems, I am still very suspicious of Xorg version related issues though specifically if fglrx is used. – Michiel Jun 19 '15 at 19:52
  • Currently it appears like the bios update has fixed it, but I'll continue testing today to make sure. If it can make it the whole day with no crashes/freezes I'll call this resolved. Stay tuned. – Spaz Static Jun 21 '15 at 17:04
  • So far so good. I'm going to give it one more day, and the bios update looks like it fixed everything. – Spaz Static Jun 22 '15 at 4:25
1

You are using an open source "radeon" driver for your video adapter.

It may not perform well. I suggest installing a proprietary AMD driver.

You can do it by running in terminal

sudo apt-get install fglrx

and reboot.

Same task can be done in GUI. You can go to

System Settings -> Software & Updates -> Additional Drivers

and find there drivers for your video adapter.

  • So far it has not helped. It is possibly even less stable now. – Spaz Static Jun 15 '15 at 23:05
0

I was experiencing freezing using 15.04. I tried the additional drivers and it did not fix. Then booted up after a freeze, went straight into the software center and simply installed all the available Nvidia software through the software center. After that, great performance everything worked nicely. Set server preference to performance, not high quality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.