2

I try to solve a problem of mine and I have some difficulties. I can't install/remove/dist-upgrade/clean/autoclean any package. When I try to run sudo apt-get -f install to fix unmet dependencies I get:

orian@orian-desktop:~$ sudo apt-get -f install
[sudo] password for orian: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
cpp-4.8-arm-linux-gnueabihf cpp-arm-linux-gnueabihf dh-apparmor diffstat
gcc-4.8-arm-linux-gnueabihf-base gettext intltool-debian lib32asan0
lib32atomic1 lib32gcc1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++6
libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
libapt-pkg-perl libarchive-zip-perl libasan0 libasan0-armhf-cross
libasprintf-dev libatomic1 libatomic1-armhf-cross libauthen-sasl-perl
libautodie-perl libbonobo2-common libbonoboui2-common
libc6-armel-armhf-cross libc6-armel-cross libc6-armhf-cross
libc6-dev-armel-armhf-cross libc6-dev-armel-cross libc6-dev-armhf-cross
libclass-accessor-perl libclone-perl libcloog-isl4 libdigest-hmac-perl
libdpkg-perl libemail-valid-perl libfile-fcntllock-perl libfs6
libgcc-4.8-dev libgcc-4.8-dev-armhf-cross libgcc1-armhf-cross
libgettextpo-dev libgettextpo0 libglade2-0 libgnome2-common
libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common
libgomp1-armhf-cross libio-pty-perl libio-socket-inet6-perl
libio-socket-ssl-perl libio-string-perl libipc-run-perl
libipc-system-simple-perl libisl10 libitm1 liblist-moreutils-perl
libmail-sendmail-perl libmailtools-perl libmpc3 libmpfr4 libnet-dns-perl
libnet-domain-tld-perl libnet-ip-perl libnet-libidn-perl
libnet-smtp-ssl-perl libnet-ssleay-perl liborbit-2-0
libparse-debianchangelog-perl libperlio-gzip-perl libquadmath0
libsfasan0-armhf-cross libsfatomic1-armhf-cross libsfgcc-4.8-dev-armhf-cross
libsfgcc1-armhf-cross libsfgomp1-armhf-cross libsfstdc++-4.8-dev-armhf-cross
libsfstdc++6-armhf-cross libsocket6-perl libstdc++-4.8-dev
libstdc++-4.8-dev-armhf-cross libstdc++6-armhf-cross libsub-identify-perl
libsub-name-perl libsys-hostname-long-perl libtext-levenshtein-perl
libtimedate-perl libtsan0 liburi-perl linux-headers-3.16.0-30
linux-headers-3.16.0-30-generic linux-image-3.16.0-30-generic
linux-image-extra-3.16.0-30-generic linux-libc-dev-armel-cross
linux-libc-dev-armhf-cross patchutils po-debconf t1utils x11-xfs-utils xinit
xorg-docs-core
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libc6-dev-amd64:i386
The following NEW packages will be installed:
libc6-dev-amd64:i386
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
16 not fully installed or removed.
Need to get 0 B/1,429 kB of archives.
After this operation, 9,590 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 244830 files and directories currently installed.)
Preparing to unpack .../libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb ...
Unpacking libc6-dev-amd64 (2.19-0ubuntu6.6) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb (--unpack):
trying to overwrite '/usr/include/gnu', which is also in package libc6-dev-i386 2.19-0ubuntu6.6
Errors were encountered while processing:
/var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried this How do I resolve unmet dependencies after adding a PPA? but I get the same error. please help me. thanks a lot, Orian.

EDIT: When I try to run sudo apt-get autoremove I get:

orian@orian-desktop:/boot$ sudo apt-get autoremove
[sudo] password for orian: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
gcc-4.8-multilib:i386 : Depends: libc6-dev-amd64:i386 (>= 2.11) but it is not installed
libc6-dev-x32:i386 : Depends: libc6-dev-amd64:i386 (= 2.19-0ubuntu6.6) but it is not installed
E: Unmet dependencies. Try using -f.

and for uname -mr:

orian@orian-desktop:/boot$ uname -mr
3.16.0-39-generic x86_64
  • Did you try sudo apt-get autoremove to clean up unused packages? Also can you run uname -mr so we can see your architecture (looking at those packages, you might have repositories for multiple architectures configured). – Wayno Jun 14 '15 at 7:27
  • please see my edit. – Orian Zinger Jun 14 '15 at 7:59
4

I think you are affected by an already reported bug in libc6-dev. There seems to be no fix provided, but one workaround (provided in Comment #4 and possibly #5 also) is to remove that package completely by:

sudo apt-get purge libc6-dev-amd64
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install -f

You can also see sudo apt-get -f install fails post

| improve this answer | |
  • Finally some dpkg --purge --force-depends "gcc-multilib" dpkg --purge --force-depends "libc6-dev-x32" worked out. Thanks a lot. – Orian Zinger Jun 14 '15 at 8:41
  • I 've been looking for this for ages. I somehow workaround the problem once or twice, without really solving it.. Thanks @Ron! – Paschalis Jul 30 '15 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.