11

I tried searching for an answer. But everyone is asking for autologin or disable passwd. But i want to put a password which on my laptop is not enabled. I tried to do this in settings but it won't work. Autologin is off. Brightness and lock settings are below.

enter image description here

I don't know what else I can do. When I lock the pc, the screen goes black and then simply wakes up to the home screen without any password. Same case happened when I suspend the laptop.

So, how can I be prompted to enter my password each time the computer wakes from sleep or activates the screensaver?

  • Could you post the output of dpkg - l | grep screensaver? That would help me see if one solution is viable :) – RPiAwesomeness Jun 13 '15 at 22:21
  • Use 'apt' or 'aptitude' for user-friendly package management; Type dpkg -Dhelp for a list of dpkg debug flag values; Type dpkg --force-help for a list of forcing options; Type dpkg-deb --help for help about manipulating *.deb files; Options marked [*] produce a lot of output - pipe it through 'less' or 'more' ! @RPiAwesomeness – arslion Jun 13 '15 at 22:39
  • i am using 14.04 LTS – arslion Jun 13 '15 at 22:43
  • And you typed it in exactly as dpkg -l | grep screensaver? – RPiAwesomeness Jun 13 '15 at 22:44
  • as you said, Yes – arslion Jun 13 '15 at 22:45
0

I tried many things but none of them works. and xscreensaver is the only alternative. After searching I finally try to update the ubuntu to the latest stable version from 14.04 to 14.10 via Software Updater and then everything will be fine.

0

Edit the file '/etc/systemd/logind.conf'

sudo nano /etc/systemd/logind.conf

Removed the # comment from the beginning of the line 'HandleLidSwitchDocked=ignore' and changed the value to be:

HandleLidSwitchDocked=suspend

Then Rebbot your system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.