4

My login manager stopped loading, for no apparent reason, instead tty7 was a black screen I could type into but with no effect. I tried several variations of service lightdm restart service sddm restart but to no avail. I tried installing gdm and running dpkg-reconfigure but this showed some strange error intel ... ERROR too many voltage tries give up. I also tried installing xdm but it also didn't work. I tried enabling the display managers with systemctl enable gdm.service systemctl enable lightdm.service. It seems x11 is okay as sudo startx starts unity seemingly okay.

Finally I gave up and restarted. Now I just get the kubuntu splash screen which never resolves to a display manager or to a tty.

Maybe I have enabled several display managers? What should I try and do next? I am currently using a try ubuntu live usb, how could I modify upstart or systemd to just enable lightdm for example?

Hope I don't have to format :-/ come on internet!

3

Okay turns out the [drm:intel_dp_start_link_train] *ERROR* too many voltage retries, give up from the kernel is a known bug but was a red herring and had nothing to do with my problems and from what I've seen people say it's not a problem. I think it has something to do with ASUS. I am using ASUS TaiChi 21.

Also running systemctl enable for several login managers wasn't too much of a problem as it just creates symbolic links in /etc/systemd/system

I fixed the splash screen not progressing to the login manager by changing the login manager to sddm, it was set to xdm. I did this by using a "Try ubuntu live" usb stick and modifying the file /etc/X11/default-display-manager from /usr/bin/xdm to /usr/bin/sddm.

In the process I learnt a little about how X11 and display managers work:

  • X11 is a network protocol. It encodes things such as graphic primitives, images, pointer motion, and key presses.
  • Xorg is an X server. It implements X11 and provides an interface to keyboards, mice, and video cards.
  • gdm, xdm, kdm sddm are all login managers (synonym display managers) They are the first X program run by the system.
  • When the computer boots, the shell scripts in /etc/rc2.d are run. There is a script for each login manager such as S03lightdm. This login manager script reads from /etc/X11/default-display-manager and decides whether to init the display manager based on this value.
  • Upon authentication the login manager calls /etc/Xsession which calls the scripts in /etc/Xsession.d/ and ~/xinitrc which then sets up your desktop environment and window manager.

So presumably there was something wrong with either the installation/config/compatibility of xdm on my computer.

Following this change I was able to see the login manager screen and was able to login but upon login it redirected me back to the login screen. This occurred due to running sudo startx which created the file ~/.Xauthority but owned by root. I finally fixed this by deleting .Xauthority and everything is back to normal!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.