11

I recently moved my computer, and after I set my speakers up again, I've had problems with outputting sound on them. It just doesn't work.

The sound card is a Asus Xonar DX. I'm running Ubuntu 15.04 with Gnome. Kernel 3.16.0-31-generic.

I get sound on it by running aplay -l, and running aplay -D plughw:2,0 /usr/share/sounds/alsa/Front_Center.wav where 2,0 represents sound card and device respectively:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD1989B Analog [AD1989B Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD1989B Digital [AD1989B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: AD1989B Alt Analog [AD1989B Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DX [Xonar DX], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: DX [Xonar DX], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This should mean that the device is connected and working, but that the problem is with sound settings?

Alsa Information

Thanks for all help, it is greatly appreciated!

EDIT: I've tried a clean install of Ubuntu Gnoem 15.04. I still have the problem. Seems it is with Pulseaudio, that it is impossible to choose my audio device with it for some reason.

EDIT2: Thought maybe it was the infamous randomsound-issue, but found that it's not.

16

This solution did not work for me for Ubuntu 18.04. But as I executed

pactl load-module module-detect

the missing built-in Audio Analog Stereo suddenly appeared in the sound settings menu. As I chose it, I was able to hear the sound.

If you want this setting permanent, add the line load-module module-detect to the default modules in /etc/pulse/default.pa

5
  • 1
    This worker for me. Was thinking it was hardware related...
    – Climax
    Jun 15 '20 at 12:33
  • 1
    Thanks - i'm on Pop!_OS 20.10 and just during the day my audio cut out and "built-in audio analog steroe" (e.g the headphone jack on the motherboard) disappeared. This brought it back.
    – bsautner
    Dec 10 '20 at 13:30
  • 1
    Thanks! Ubuntu 20.04.1 and this solved my issue
    – Zoidberg
    Dec 23 '20 at 0:53
  • On Ubuntu 20.04, /etc/pulse/default.pa already contains this (but did not work): ### Automatically load driver modules depending on the hardware available .ifexists module-udev-detect.so load-module module-udev-detect .else ### Use the static hardware detection module (for systems that lack udev support) load-module module-detect .endif So, maybe some problem related to udev originally? Jun 3 at 9:07
  • @MarkusJunginger Check if your sound device is recognized at all, that means do you see it with #lshw? If not, then maybe you need to install drivers first. If it's recognized, but not loaded, then either you gave to load it or maybe another module is blocking it and you have to blacklist the blocking module, difficult to say now. I had similar issues with my new computer. My network controller is too new, so I had to install drivers first and then I had to manually blacklist another module to get the correct network module working. Obviously it worked automatically after installing the driver
    – Bevor
    Jun 5 at 8:47
9

I managed to solve this, although not a optimal solution, it'll work.

I installed PulseAudio Volume Control. Then went to "Configuration" and under the correct sound card, I chose the correct output (Analog 5.1).

PulseAudio Volume Control

Then it shows up in sound settings again. Although, if I change the device in Sound Settings, I sometimes have to open PulseAudio Volume Control the analog sound show up again.

Sound Settings

Thanks to this question and answer.

1

******mine was same like you i upgraded from 14.10 to 15.04 and i fix it**** following these steps**

  • open terminal type :sudo apt-get install pavucontrol

open pavuontrol from terminal or dashboard

  • Then At configuration tab choose in built in audio then choose "analog stereo duplex"

  • Now choose headphones in output device tabs instead of line-out!

use your earphone/headset to check first

then you have sound now play song videos any-thing ;) enjOy goodday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.