2

When booting Ubuntu 14.04 server LTS with more than 4gb Ram the computer displays a black screen. I have an Asrock D1800B-ITX motherboard. The processor is an Intel Celeron J1800 (64 bit processor) it boots fine when I only use one stick of ram but when inserting the other Ubuntu just shows a blinking line.

The 2 GB stick's model number is HMT351S6CFR8C-H9 The 4 GB stick's model number is HMT125S6DFR8C-H9.

I have 1 4GB stick and 1 2GB stick neither of which are faulty.

It is in fact 64 bit I ran uname -m and it returned: x86_64

It doesn't work with 15.04 (desktop and server) either.

I have the latest version of the BIOS (I guess nowadays they call it "UEFI") from Asrock

Results of dmidecode -t memory (With 4GB stick)

# dmidecode 2.12
SMBIOS 2.8 present.

Handle 0x000A, DMI type 16, 23 bytes
Physical Memory Array
    Location: System Board Or Motherboard
    Use: System Memory
    Error Correction Type: None
    Maximum Capacity: 64 GB
    Error Information Handle: Not Provided
    Number Of Devices: 2

Handle 0x000C, DMI type 17, 40 bytes
Memory Device
    Array Handle: 0x000A
    Error Information Handle: Not Provided
    Total Width: 64 bits
    Data Width: 64 bits
    Size: 4096 MB
    Form Factor: DIMM
    Set: None
    Locator: A1_DIMM0
    Bank Locator: A1_BANK0
    Type: DDR3
    Type Detail: Unknown
    Speed: 1333 MHz
    Manufacturer: Hynix Semiconduc
    Serial Number: SNIP!  
    Asset Tag: A1_AssetTagNum0
    Part Number: HMT351S6CFR8C-H9  
    Rank: 2
    Configured Clock Speed: 1333 MHz
    Minimum voltage:  6.296 V
    Maximum voltage:  -21.482 V
    Configured voltage:  Unknown

Handle 0x000E, DMI type 17, 40 bytes
Memory Device
    Array Handle: 0x000A
    Error Information Handle: Not Provided
    Total Width: Unknown
    Data Width: 64 bits
    Size: No Module Installed
    Form Factor: DIMM
    Set: None
    Locator: A1_DIMM1
    Bank Locator: A1_BANK1
    Type: Unknown
    Type Detail: Unknown
    Speed: Unknown
    Manufacturer: A1_Manufacturer1
    Serial Number: A1_SerNum1
    Asset Tag: A1_AssetTagNum1
    Part Number: Array1_PartNumber1
    Rank: Unknown
    Configured Clock Speed: Unknown
    Minimum voltage:  -21.061 V
    Maximum voltage:  Unknown
    Configured voltage:  Unknown

The second memory bank is empty as I can't boot with it connected which is the issue

Output of lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Output of lspci

00:00.0 Host bridge: Intel Corporation ValleyView SSA-CUnit (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0e)
00:13.0 SATA controller: Intel Corporation ValleyView 6-Port SATA AHCI Controller (rev 0e)
00:14.0 USB controller: Intel Corporation ValleyView USB xHCI Host Controller (rev 0e)
00:1a.0 Encryption controller: Intel Corporation ValleyView SEC (rev 0e)
00:1b.0 Audio device: Intel Corporation ValleyView High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0e)
00:1c.1 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0e)
00:1c.2 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0e)
00:1c.3 PCI bridge: Intel Corporation ValleyView PCI Express Root Port (rev 0e)
00:1f.0 ISA bridge: Intel Corporation ValleyView Power Control Unit (rev 0e)
00:1f.3 SMBus: Intel Corporation ValleyView SMBus Controller (rev 0e)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)

I've tried booting dozens of versions of dozens of different Operating Systems and they all do more or less the same thing (Including Windows)

On Windows 7, it just shows "Starting Windows" (Without the logo)

  • 3
    This is not about Ubuntu, but about your motherboard and memory sticks compatibility and configuration. – Pilot6 Jun 14 '15 at 19:19
  • 1
    @Pilot6 Actually it kind of is. I think that it is a bug that the OS doesn't handle the memory properly – Grammargeek Jun 14 '15 at 19:20
  • 3
    No. It is the motherboard that does not accept this combination of memory sticks. You can look into motherboard manual. – Pilot6 Jun 14 '15 at 19:21
  • 1
    My 4GB stick's model number is HMT351S6CFR8C-H9 – Grammargeek Jul 5 '15 at 20:13
  • 2
    @daltonfury42 The 2GB stick's model number is HMT125S6DFR8C-H9 – Grammargeek Jul 6 '15 at 22:17
1
+50

Both seem to be Hynix memory chips but on the Hynix web site, I can only find the technical specifications of the HMT351S6CFR8C and not the HMT125S6DFR8C, so I cannot compare tech specs to see whether they even can work together there...

However, I found a product catalog on the Hynix web site and that confirms my suspicion: the HMT351S6CFR8C-H9 has a timing of 1333-9-9-9 and the HMT125S6DFR8C-H9 a timing of 1600-11-11-11, so individually they work, (probably because you've got a motherboard that supports both timings) but they're most likely not compatible with each other on your motherboard!.

Sorry to be the harbinger of bad news.

If I were you, I would get 2*4GB HMT351S6CFR8C-H9 chips. That way your motherboard will have chips with identical timing: it's not so much the size that matters ... but the timing of the chips must be equal!

  • Thanks, Is there any possibility of lowering the timing of the HMT125S6DFR8C-H9? (If not, I need to go give the guys at the computer store a sterna talking to :)) – Grammargeek Jul 7 '15 at 23:09
  • Not with current technology... Take the laptop to them and ask them to test 2 identical chips. And don't thank me! ;-) If you like my answer, just click the little grey under the "0" now turning it into beautiful green. If you do not like my answer, click on the little grey down-arrow below the 0, and if you really like my answer, click on the little grey checkmark and the little up-arrow... If you have any further questions, go to askubuntu.com/questions/ask – Fabby Jul 7 '15 at 23:13
  • Take the PC/Motherboard to the store... – Fabby Jul 8 '15 at 10:08
  • Alright should be able to do it today (hopefully) – Grammargeek Jul 8 '15 at 11:49
  • 1
    We were thinking the same thing... I sometimes assume that what's in my head is also in the OP's... ;-) – Fabby Jul 11 '15 at 12:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.