I recently upgraded to Ubuntu 15.04. When I run optirun -vv glxinfo, I get:

[ 790.194984] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf

[ 790.195278] [DEBUG]optirun version 3.2.1 starting...

[ 790.195292] [DEBUG]Active configuration:

[ 790.195299] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf

[ 790.195307] [DEBUG] X display: :8

[ 790.195315] [DEBUG] LD_LIBRARY_PATH:

[ 790.195323] [DEBUG] Socket path: /var/run/bumblebee.socket

[ 790.195330] [DEBUG] Accel/display bridge: auto

[ 790.195338] [DEBUG] VGL Compression: proxy

[ 790.195345] [DEBUG] VGLrun extra options:

[ 790.195353] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus

[ 790.195394] [DEBUG]Using auto-detected bridge primus

[ 790.196751] [INFO]Response: No - error: Could not load GPU driver

[ 790.196777] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 790.196793] [DEBUG]Socket closed.

[ 790.196815] [ERROR]Aborting because fallback start is disabled.

[ 790.196831] [DEBUG]Killing all remaining processes.

Here is my /etc/bumblebee/bumblebee.conf:

\# Configuration file for Bumblebee. Values should **not** be put between quotes

\#\# Server options. Any change made in this section will need a server restart
\# to take effect.
\# The secondary Xorg server DISPLAY number
\# Should the unused Xorg server be kept running? Set this to true if waiting
\# for X to be ready is too long and don't need power management at all.
\# The name of the Bumbleblee server group name (GID name)
\# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
\# server exits.
\# The default behavior of '-f' option on optirun. If set to "true", '-f' will
\# be ignored.
\# The Driver used by Bumblebee server. If this value is not set (or empty),
\# auto-detection is performed. The available drivers are nvidia and nouveau
\# (See also the driver-specific sections below)
\# Directory with a dummy config file to pass as a -configdir to secondary X

\#\# Client options. Will take effect on the next optirun executed.
\# Acceleration/ rendering bridge, possible values are auto, virtualgl and
\# primus.
\# The method used for VirtualGL to transport frames between X servers.
\# Possible values are proxy, jpeg, rgb, xv and yuv.
\# List of paths which are searched for the primus libGL.so.1 when using
\# the primus bridge
\# Should the program run under optirun even if Bumblebee server or nvidia card
\# is not available?

\# Driver-specific settings are grouped under [driver-NAME]. The sections are
\# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
\# detection resolves to NAME).
\# PMMethod: method to use for saving power by disabling the nvidia card, valid
\# values are: auto - automatically detect which PM method to use
\#         bbswitch - new in BB 3, recommended if available
\#       switcheroo - vga_switcheroo method, use at your own risk
\#             none - disable PM completely
\# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

\#\# Section with nvidia driver specific options, only parsed if Driver=nvidia
\# Module name to load, defaults to Driver if empty or unset
\# colon-separated path to the nvidia libraries
\# comma-separated path of the directory containing nvidia_drv.so and the
\# default Xorg modules path

\#\# Section with nouveau driver specific options, only parsed if Driver=nouveau

I already tried reinstalling everything related to bumblebee and nvidia. I've run sudo systemctl enable bumblebeed.

cat /proc/acpi/bbswitch prints 0000:01:00.0 ON.

After running optirun glxinfo and subsequently lsmod | grep nvidia, I get no output, but after sudo modprobe nvidia-304, lsmod finds the nvidia module again.

I have a Lenovo Thinkpad T530 with an Nvidia NVS 5400 GPU and another integrated Intel chip.

I hope I've given enough information for someone to help me fix my problem. Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.