3

I have an ASUS F552CL laptop with Ubuntu 15.04 installed.

The laptop comes with a dedicated nVidia GeForce GT 710M graphics card.

I have installed and enabled all the proprietary drivers suggested in Software Updates - Additional Drivers:

screenshot1

When I try to switch to the dedicated graphics card using NVIDIA X Server Settings, a message pops up asking me to log out and log back in to apply the changes:

screenshot2

And it looks like the dedicated graphics card has been selected:

enter image description here

However, if I log out and log back in the integrated graphics card shows up as the card in use:

enter image description here

I also tried to reboot instead of to log out and log back in but the integrated graphics card keeps showing up as the card in use.

When I run gksudo nvidia-settings in Terminal, after having closed NVIDIA X Server Settings I get the following message:

ERROR: nvidia-settings could not find the registry key file. This file
       should have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       preopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.
  • 2
    did you use gksudo? Once I had similar situation when I simply launch nvidia-settings the result won't affect when run with gksudo and vice versa. – JoKeR Jun 11 '15 at 23:07
  • 1
    Please add possible error output from running nvidia-settings from a terminal. It may be that you are affected by this bug – s3lph Jun 11 '15 at 23:07
  • @JoKeR Thanks for the suggestion, but I've always started NVIDIA X Settings from the dash – kos Jun 11 '15 at 23:17
  • @the_Seppi Good catch. That's it (same identical message). If you want to post that as an answer I'll accept it. – kos Jun 11 '15 at 23:18
3

There is a known bug to nvidia settings: Bug #1341140.

If you receive the following error message, you are probably affected by it:

ERROR: nvidia-settings could not find the registry key file.
This file should have been installed along with this driver at either
/usr/share/nvidia/nvidia-application-profiles-337.25-key-documentation or
/usr/share/nvidia/nvidia-application-profiles-key-documentation.
The application profiles will continue to work, but values cannot be preopulated
or validated, and will not be listed in the help text.
Please see the README for possible values and descriptions.

There is a workaround to this bug, also contained in the bug report. Execute the following from a root shell, replacing the 340.24 by the actual driver number. (I yet have to find out what they mean...)

mkdir -p /etc/nvidia
cd /etc/nvidia
ln -s /etc/alternatives/x86_64-linux-gnu_nvidia_app_profile_keys nvidia-application-profiles-340.24-key-documentation
ln -s /etc/alternatives/x86_64-linux-gnu_nvidia_app_profile nvidia-application-profiles-340.24-rc

Now the problem should be fixed, according to the bug report.


EDIT: The OP mentioned that he had to alter above commands as follows:

cd /usr/share/nvidia
mv nvidia-application-profiles-340.76-key-documentation nvidia-application-profiles-key-documentation
mv nvidia-application-profiles-340.76-rc nvidia-application-profiles-rc
|improve this answer|||||
  • Thanks, however this didn't work, and I managed to solve it in a different way. See my update on the question to read the exact error message. I had to change the filenames of the symbolic links in /usr/share/nvidia (nvidia-application-profiles-340.76-key-documentation and nvidia-application-profiles-340.76-rc in my case) to nvidia-application-profiles-key-documentation and nvidia-application-profiles-340.76-rc as the error message implicitly suggests – kos Jun 11 '15 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.