When I try to login, it reverts me to the login screen. If I move my mouse, it shows a log of system events and then does the same thing. I can Clrl + Alt + F1 to a terminal, and do modifications from there. I've attempted several fixes, some finished, some halted due to other roadblocks.

I think the core of the problem is something to do with my Nvidia driver (vs the graphics card) and I got another error along the lines of "failure to load start kernel drivers".

Would my best bet be to reinstall from a live CD? I can give more specific info to any queries later.

Here's some output:

systemctl status systemd-modules-load.service
[1;31m●[0m systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static;     vendor preset: enabled)
   Active: [1;31mfailed[0m (Result: exit-code) since Fri 2015-06-12 17:26:33     BST; 1min 17s ago
     Docs: man:systemd-modules-load.service(8)
  Process: 419 ExecStart=/lib/systemd/systemd-modules-load [1;31m(code=exited, status=1/FAILURE)[0m
 Main PID: 419 (code=exited, status=1/FAILURE)

Jun 12 17:26:33 me-GA-78LMT-USB3 systemd[1]: Starting Load Kernel Modules...
Jun 12 17:26:33 me-GA-78LMT-USB3 systemd-modules-load[419]: Module 'fuse' is builtin
Jun 12 17:26:33 me-GA-78LMT-USB3 systemd[1]: [1;39msystemd-modules-load.service: main process exited, code=exited, status=1/FAILURE[0m
Jun 12 17:26:33 me-GA-78LMT-USB3 systemd[1]: [1;31mFailed to start Load Kernel Modules.[0m
Jun 12 17:26:33 me-GA-78LMT-USB3 systemd[1]: [1;39mUnit systemd-modules-load.service entered failed state.[0m
Jun 12 17:26:33 me-GA-78LMT-USB3 systemd[1]: [1;39msystemd-modules-load.service failed.[0m
  • You mentioned that you've attempted some fixes. What exactly you've done so far ? – Sergiy Kolodyazhnyy Jun 11 '15 at 19:41
  • For one I tried this but couldn't do step 4 because it said something like "no such installation for bbswitch". So I couldn't progress there. I also tried adding "nomodeset" to GRUB_CMDLINE_LINUX_DEFAULT= and deleting "quiet mode splash" but no joy at all. – Tartan_Spartan Jun 11 '15 at 19:50
  • Ok, login into Ctrl + Alt + F1 or F 2 , and let me know what does output of ls -l ~/.Xauthority look like – Sergiy Kolodyazhnyy Jun 11 '15 at 19:52
  • Ok, will have to be tomorrow from 0800 GMT though. Thanks so far! BTW, is there a CLI/terminal logger I can install to record the output? – Tartan_Spartan Jun 11 '15 at 19:56
  • I attempted to write that command in exactly, but no joy. "No such file or directory". – Tartan_Spartan Jun 12 '15 at 14:59
sudo apt-get install lightdm.

If lightdm is already installed then...

sudo systemctl disable sddm.service
sudo systemctl enable lightdm.service

You will now see the gnome greeter and will now boot and reboot every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.