0

I am running Ubuntu Server 14.04.2 LTS and lately the system partion often runs out of space. I clean up what I can with the standard apt-get autoremove etc. commands, but that only gives me back some MBs.

Now I tried to find out where all the space is gone and ... I simply don't find out where it is. According to

df -h

Filesystem                 Size  Used Avail Use% Mounted on
/dev/mapper/stig--vg-root   12G   11G  386M  97% /
none                       4.0K     0  4.0K   0% /sys/fs/cgroup
udev                       7.8G   12K  7.8G   1% /dev
tmpfs                      1.6G  1.9M  1.6G   1% /run
none                       5.0M     0  5.0M   0% /run/lock
none                       7.8G  4.0K  7.8G   1% /run/shm
none                       100M     0  100M   0% /run/user
/dev/sdf1                  236M   68M  156M  31% /boot
/dev/sdb1                  2.7T  2.1T  551G  79% /data/disk1
/dev/sda1                  2.7T  2.1T  498G  81% /data/disk1b
/dev/sdc1                  1.8T  520G  1.2T  30% /data/disk2
/dev/sdd1                  1.8T  521G  1.2T  30% /data/disk2b
/dev/sde1                  688G  522G  132G  80% /data/disk3
/dev/sdg1                  932G  522G  410G  56% /data/usb.disk3b
/dev/sdh1                  932G  522G  410G  57% /data/usb.disk2c

There are 11 gigs in use on /dev/mapper/stig--vg-root ... but I failed to find out where. I tried with

sudo ncdu -o ~/ncduoutput

in the root directory. Here is the output:

ncdu 1.10 ~ Use the arrow keys to navigate, press ? for help                                                                                                                                                                           [imported]
--- / ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    6.6TiB [ 99.9%] /data
    2.5GiB [  0.0%] /usr
  969.9MiB [  0.0%] /var
  292.6MiB [  0.0%] /lib
  178.9MiB [  0.0%] /home
   36.6MiB [  0.0%] /boot
   28.7MiB [  0.0%] /etc
   12.1MiB [  0.0%] /sbin
    9.6MiB [  0.0%] /bin
    1.9MiB [  0.0%] /tmp
    1.8MiB [  0.0%] /run
  104.0KiB [  0.0%] /root
   20.0KiB [  0.0%] /storage
e  16.0KiB [  0.0%] /lost+found
   12.0KiB [  0.0%] /dev
   12.0KiB [  0.0%]  webmin-setup.out
    8.0KiB [  0.0%] /opt
    4.0KiB [  0.0%] /lib64
e   4.0KiB [  0.0%] /srv
e   4.0KiB [  0.0%] /mnt
    4.0KiB [  0.0%]  dead.letter
.   0.0  B [  0.0%] /proc
    0.0  B [  0.0%] /sys
@   0.0  B [  0.0%]  initrd.img
@   0.0  B [  0.0%]  vmlinuz

Leaving /data asside (which resides on other disks), the other stuff doesn't even add up to 11 gigs.

Anyone can give me a hint what I might miss? Or does this sound like a disk fault? I didn't run any fsck, but that might be the next step unless anyone could tell me I did something wrong or have overseen something.

Many thanks in advance :).

0

If you have any data in the real /boot and /data directories on your root partition, they are not visible while you have another filesystem mounted over those directories. You can check their contents without the other filesystems getting in the way by bind mounting your root somewhere else and then checking there:

mount --bind / /mnt
du -sh /mnt/boot /mnt/data
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.