I don't know what I did in gedit (and nautilus), but menu bar gone away. Here a screenshot. Actually, menu bar changed but I like the "classic" way, with "File, Edit...". What I did wrong and how I can I fix this?

I am using Ubuntu 14.04.

enter image description here

  • 1
    Move the mouse cursor to the top left corner do you see your menu there? I mean does the global menu now is working instead of local menu?
    – Maythux
    Commented Jun 11, 2015 at 12:37
  • Take a look at this forum post. It says the problem is with ongoing GTK+3.12 client side decorations. Seems you either have to wait, or change to another editor, like medit.
    – hingev
    Commented Jun 11, 2015 at 12:43
  • Thanks. It's about GTK+ 3.12. I will start to use medit until this issue get fixed.
    – humungs
    Commented Jun 11, 2015 at 13:15
  • 7
    Possible duplicate of gedit top menu invisible when started from terminal and using x11-Forwarding
    – Fabby
    Commented Dec 21, 2015 at 22:20

4 Answers 4


if you are using GNOME 3, you can access the preferences via the top menu.

you should have "activities" on the top left corner of your screen. on the right side of activities, you will have gedit. click on it, and you should see the preferences.


Read this: https://bugs.launchpad.net/bugs/1542489

I decided to use pluma instead of gedit:

sudo apt-get install pluma

It looks just like gedit did about 2 versions ago. This will work fine (for me) until gedit gets straightened out.


I had a same problem with applications like LibreOffice 5 and terminal and gedit. Menu bar was missing from both of this applications. It occurred after upgrading Ubuntu to 16.04 from 14.04... I used following two commands and it worked for me...

WARNING: resets all compiz settings.

dconf reset -f /org/compiz/
setsid unity

Use above two commands and I hope it will work for you also...

  • 6
    You should at least explain that the first command resets all user settings related to Compiz. Commented May 1, 2016 at 20:16
  • yes, after resetting compiz, it all worked again. thanks
    – azerafati
    Commented May 7, 2016 at 13:13

Some of gedit's menu items can only be seen when the indicator-appmenu is installed. Try this:

sudo apt-get install indicator-appmenu

Logout and login again. See if the menu of the gedit application appears on the top of the screen (not on top of the application window). If it does, you should be able to find Preferences option there.

If you don't like the menu to appear on the top of the screen (such as I), you may remove it afterward.

sudo apt-get remove indicator-appmenu

Don't forget to logout and login again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .