6

Chrome has gone large in all senses - the whole window, tabs, font. See the picture below.

I tried this following suggestion on this post, but not luck fixing it.

All I did is this:

- gsettings set org.gnome.desktop.interface font-name 'Sans 11'
- google-chrome
- gsettings set org.gnome.desktop.interface font-name 'Sans 13'

Here is my return to google-chrom --version Google Chrome 43.0.2357.124

enter image description here

4
  • When you say all you did was - gsettings set org.gnome.desktop.interface font-name 'Sans 11' - google-chrome - gsettings set org.gnome.desktop.interface font-name 'Sans 13', what exactly do you mean? Did you run that in Terminal? Or...?
    – user364819
    Commented Jun 11, 2015 at 8:44
  • yes, ctrl+alt+t -> copy and paste one link at a time. I run it as sudo as well. I wasn't sure If i need it or not..
    – Serine
    Commented Jun 11, 2015 at 9:00
  • So to try to fix the problem you ran each of those line by line?
    – user364819
    Commented Jun 11, 2015 at 9:39
  • Just to add a bit more weight to my question, look like there was a actual bug posted on chrome releases page and here is another comment on reddit about this issue
    – Serine
    Commented Jun 11, 2015 at 23:36

4 Answers 4

11

For me the following worked:

google-chrome --high-dpi-support=1 --force-device-scale-factor=1

make sure you kill all running instances of google chrome, otherwise it will just open another (broken) window ignoring the command line parameters

1
  • 1
    I thank all of the users who has contributed to this discussion. My problem has been fixed using the command above.
    – Serine
    Commented Jun 11, 2015 at 23:18
4

solution is to add flag --force-device-scale-factor in the file /usr/bin/chromium-browser or in /usr/bin/google-chrome

For solving error in chromium browser, I added the following line

CHROMIUM_FLAGS="$CHROMIUM_FLAGS --force-device-scale-factor=1"

after the CHROMIUM_FLAGS definition in the script "/usr/bin/chromium-browser", ( for me it was line 185 )

for /usr/bin/google-chrome you should add the same parameter but in other way, ( sorry on my side the bug was only on chromium )

2
  • A similar change to Session and Startup » Application Autostart » Chromium worked for me in Xubuntu after an update. Commented Sep 6, 2016 at 22:13
  • You should better use ~/.chromium-browser.init , because /usr/bin/chromium-browser will be overwritten on browser package update. Commented Sep 12, 2016 at 7:44
1

I just ran an update and the problem resolved as part of the update.

Version 43.0.2357.125 (64-bit)

Update Chrome.

2
  • Same here. google-chrome-stable amd64 43.0.2357.125-1 fixed the issue. Ubuntu 14.04 LTS
    – sastorsl
    Commented Jun 11, 2015 at 20:29
  • @NotMy1RealName thanks for the answer, but I couldn't find the where to download the latest chrome .125-1.. All found is this link I'm guessing your built from source..? I'm sure how to do that. If you know there to get .deb package I will much appreciate that. thanks
    – Serine
    Commented Jun 11, 2015 at 23:28
0

I tried the

$CHROMIUM="$CHROMIUM_FLAGS --force-device-scale-factor=1"

modification, however it did not work. Instead, I used @fetteelke's suggestion, and just ran the following commands:

cd /usr/bin
sudo echo '#! /bin/bash' | tee /opt/google/chrome/google-chrome-hack
sudo echo '/opt/google/chrome/google-chrome  --high-dpi-support=1 --force-device-scale-factor=1' >> /opt/google/chrome/google-chrome-hack
sudo chmod 755 /opt/google/chrome/google-chrome-rtisma-hack
sudo mv  google-chrome-stable  google-chrome-stable.backup
sudo ln -s /opt/google/chrome/google-chrome-hack  google-chrome-stable

and now everything is working fine. I am using the latest Ubuntu release.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .