1

I recently replaced a secondary internal hard drive that died. The new one worked for several days and then suddenly I got an 'unable to mount hard drive' message when booting up. I wasn't able to mount it manually, so I reformatted it.

It seems to be working now, but I'm getting a confusing unable to mount/access hard drive message again when booting up. Only now if I press s to skip, the hard drive will actually be mounted correctly when it boots up. I set the options in the disks utility to mount it to /media/username/4TB_Storage. Could a start-up script (like /etc/rc.local or /etc/profile) be trying to run before the drive is mounted? Is there a way to find out what is running when I get that start-up error?

  • 1
    Check whether the UUIDs yielded by sudo blkid match those in the file /etc/fstab. – s3lph Jun 10 '15 at 22:05
  • 1
    Thanks for the suggestion. I checked and noticed that there was an extra entry in fstab for some reason mounting to /media/4TB_Storage in addition to the correct entry mounting to /media/username/4TB_Storage. Not sure why there were two entries, but I deleted the extra one and didn't get the error message anymore. – user1389840 Jun 10 '15 at 22:40
0

When swapping hard drives, it almost always happens that the partition UUIDs of the new drive don't match the entry in the filesystem table, if the drive is supposed to be auto-mounted.

You can get a list of the current UUID's using this command:

sudo blkid

Now look into your filesystem table (/etc/fstab) and check whether there is an UUID mismatch.

If there indeed is, do the following to fix your auto-mount issues:

  • If the new drive is already in the fstab, delete orphan entries of the old, replaced drive.

  • Else, simply replace the old UUID by the new one obtained from blkid. Make sure you choose the correct matching of UUID and device file. The output of blkid and the install-time generated comments in the fstab might prove helpful.

The changes will be applied immediately, i.e. the next mounting or unmounting of a file will rely on the updated fstab. As your problem occurs on boot, reboot in order to see whether it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.