0

I like using Mediaelch. When I replaced my Ubuntu 14.04 with a fresh 15.04 installation, apt-get kept giving me not-found errors when looking for Mediaelch's packages.

I followed the instructions at Mediaelch, and its overview at Launchpad. No joy either way.

I'm guessing the repository hasn't been updated yet for 15.04.

1

I was able to install Mediaelch in Ubuntu 15.04 (Vivid) using the source for 14.04.

Method: 1 Adding Repository and Signing Key

Turns out adding a repo and its key manually is no big deal. Create a file, add the info from Launchpad, add the key, update and install:

sudo sh -c 'printf "deb http://ppa.launchpad.net/kvibes/mediaelch/ubuntu trusty main\n deb-src http://ppa.launchpad.net/kvibes/mediaelch/ubuntu trusty main\n" > /etc/apt/sources.list.d/kvibes-mediaelch-ubuntu-trusty.list'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 00DAEE81 && echo That worked. || echo That totally failed.
sudo apt-get update && sudo apt-get install mediaelch

Not so hard afterall.

Method: 2 Add New Repo and Edit for Older Source

Don't know anything about manually adding repos and signing keys, so I just added the repository according to instructions and merely replaced "vivid" with "trusty" in its list file. I didn't bother renaming the .list file.

sudo apt-add-repository ppa:kvibes/mediaelch
sudo sh -c 'sed -i "s/vivid/trusty/g" /etc/apt/sources.list.d/kvibes-ubuntu-mediaelch-vivid.list'

Then just update and install

sudo apt-get update && sudo apt-get install mediaelch

Worked a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.