2

I just built a PC and the sound test for HDMI in Phonon works but no other app does. My audio device is :ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]. I'm running Kubuntu 11.04. It works when i plug in speakers in audio out. I can give any other hardware info if needed.

1

Not sure about KDE but with Gnome, you need to change the output device in sound preferences if you want the sound to go to the TV instead of the standard output.

1

If you are getting sound on the speakers and not on the HDMI connection on your Tv you need to select the proper sound device for audio output.

Check the wiki for further assistance on how to select the right output device, I am not familiar with the KDE control panel but I have found this that might help you do it.

http://pulseaudio.org/wiki/KDE

I have the same hardware as you do, so its not a driver issue (I'm assuming you have the ubuntu binaries installed, even tough I don't believe the official driver package from ATI would be a problem) or pulse, it works with me fine.

Have a look at the wiki and gl ;)

0

System Settings -> Multimedia -> Phonon

You will see many categories, such as "Audio Playback -> Notifications". For each category you can specify which sound device is preferred.

0

Answering for Kubuntu 18.04 Plasma 5.12

1- Go to PulseAudio Volume Control
2- Configuration
3- Profile: Select "Digital Stereo (HDMI) Output"
4- (Optional) System Settings -> Multimedia -> Audio Volume -> Advanced: Check the box "Automatically switch all running streams when a new output becomes available" this way you will not have to repeat steps 1-3 every time you plug in the HDMI cable to your TV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.