1

I couldn't get my intel N6300 wireless card to work in AP mode.

$lspci|grep 6300
03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)

It is uploading the latest firmware as below, but when I do "iw list", it doesn't show AP mode in list of modes supported. I crosschecked with the intel linux drivers website and the firmware is latest. I am running Ubuntu 14.04

[ 1131.230320] iwlwifi 0000:03:00.0: irq 47 for MSI/MSI-X
[ 1131.248261] iwlwifi 0000:03:00.0: Direct firmware load failed with error -2
[ 1131.248272] iwlwifi 0000:03:00.0: Falling back to user helper
[ 1131.249113] iwlwifi 0000:03:00.0: Direct firmware load failed with error -2
[ 1131.249117] iwlwifi 0000:03:00.0: Falling back to user helper
[ 1131.267741] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm

Tried ndiswrapper, and got the below error, which as per googling found couldn't be resolved at all.

[  357.174737] ndiswrapper version 1.59 loaded (smp=yes, preempt=no)
[  357.191707] ndiswrapper (import:232): unknown symbol: ntoskrnl.exe:'MmGetSystemRoutineAddress'
[  357.191720] ndiswrapper (import:232): unknown symbol: ntoskrnl.exe:'IoWMIWriteEvent'
[  357.191745] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMFreePort'
[  357.191752] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMSetMiniportAttributes'
[  357.191761] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMIndicateStatusEx'
[  357.191769] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMDeregisterMiniportDriver'
[  357.191789] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMRegisterMiniportDriver'
[  357.191801] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMOidRequestComplete'
[  357.191813] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMNetPnPEvent'
[  357.191838] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMResetComplete'
[  357.191879] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMRegisterInterruptEx'
[  357.191898] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMSynchronizeWithInterruptEx'
[  357.191909] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMDeregisterInterruptEx'
[  357.191921] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisQueueIoWorkItem'
[  357.191927] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMFreeNetBufferSGList'
[  357.191933] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisFreeIoWorkItem'
[  357.191939] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisCancelTimerObject'
[  357.191945] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisOpenConfigurationEx'
[  357.191951] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisSetTimerObject'
[  357.191957] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMGetBusData'
[  357.191963] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisGetSystemUpTimeEx'
[  357.191969] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferAndNetBufferList'
[  357.191975] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisFreeTimerObject'
[  357.191981] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisAllocateIoWorkItem'
[  357.191987] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisFreeNetBufferListPool'
[  357.192002] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisFreeNetBufferList'
[  357.192019] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMAllocatePort'
[  357.192029] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisFreeMdl'
[  357.192038] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMAllocateNetBufferSGList'
[  357.192048] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMDeregisterScatterGatherDma'
[  357.192058] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisAllocateTimerObject'
[  357.192068] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMIndicateReceiveNetBufferLists'
[  357.192078] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMRegisterScatterGatherDma'
[  357.192088] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisAllocateMdl'
[  357.192097] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisCopyFromNetBufferToNetBuffer'
[  357.192107] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferListPool'
[  357.192117] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMSetBusData'
[  357.192126] ndiswrapper (import:232): unknown symbol: NDIS.SYS:'NdisMSendNetBufferListsComplete'
[  357.192130] ndiswrapper (load_sys_files:200): couldn't prepare driver 'netwsw00'
[  357.193692] ndiswrapper (load_wrap_driver:103): couldn't load driver netwsw00; check system log for messages from 'loadndisdriver'

In the below link one person claims AP mode working for a similar card (that card also supports soft AP mode as per it's documentation)

Ubuntu 14.04 + hostapd + 802.11a + iwlwifi = no AP!

1

I am afraid you are asking for a hardware/firmware/driver combination to perform as it was never designed to do. My similar Intel 6200 also does not support AP mode:

Supported interface modes:
         * IBSS
         * managed
         * monitor

I have or have owned five Intel wireless devices over the years and know of no method to force this capability where it was never designed to do.

As for ndiswrapper, I am skeptical that Windows XP drivers will enable features that are otherwise unavailable. Did you use XP drivers appropriate to your architecture; either 32- or 64-bit? ndiswrapper requires XP drivers and I am suspicious that your errors are related to Windows 7 or 8 driver files. Here is a quote from man ndiswrapper-1.9:

ndiswrapper is two parts: user space tool that is used to install Windows XP drivers and kernel module to load the Windows XP drivers. Both are called ndiswrapper.

  • Hi Chili I tried XP, VISTA, Windows-7 both 32 and 64 bit variants, every driver has unknown symbol issue. But 6300 has soft AP mode support as per it's user doc from intel website. In windows it shows that it supports. The same laptop, when I move to ubuntu should work as well I believe – King Jun 10 '15 at 13:16
  • My answer is the same. The driver and firmware for the device, which are supplied by Intel, by the way, don't support it. From the driver modinfo: "author: Copyright(c) 2003- 2014 Intel Corporation <ilw@linux.intel.com>" – chili555 Jun 10 '15 at 13:26
  • Hmm, wonder why they are supporting for 3160, and not this wireless card, though both mention in their docs, that they support Soft AP mode as per intel website. As per intel linux drivers website wireless.wiki.kernel.org/en/users/drivers/iwlwifi AP mode is experimental working on some drivers/firmwares. Let's wait for some more time to see if someone had made it work – King Jun 10 '15 at 16:52
  • Moved to Qualcomm Atheros 9K card. Now I am able to make it in AP mode using hostapd. I have mailed intel guys also, they didn't respond. So, we can conclude that this card doesn't support AP mode due to lack of firmware support. – King Jun 23 '15 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.