In Ubuntu 14.04, after arriving at the lightdm login screen and entering my password, the screen briefly disappears, but then comes back to the login screen. When going to terminal with ALT-CTR-F1 and doing sudo startx I get into X but no top and side bar.

With sudo startx unity I see the side bar but no status bar. And the screen looks weird and does not work well.

I did not change anything to my configuration, I guess it has been some automatic update.

Any suggestion as to how to solve this? I really do not want to reinstall.

  • 1
    possible duplicate of Unity doesn't load, no Launcher, no Dash appears
    – user404182
    Jun 9, 2015 at 20:44
  • also askubuntu.com/questions/468204/…
    – JoKeR
    Jun 9, 2015 at 20:47
  • 1
    @Dario: tried that one but did not work. I do not want to mess too much with my system. These answers were from older versions and occur after a successful login. I am stopped at the login screen, so I do not even know it is unity. Maybe unity works perfectly but I cannot start it from terminal? It is not my password. Same occurs when I set lightdm to autologin.
    – tihe
    Jun 9, 2015 at 21:02
  • Machine model? ram? (some machines are pretty marginal for unity). Do you have Nvidia video chips (lspci -v)? Which driver are you using. (lsmod to list them). Any of these may cause your symptoms.
    – ubfan1
    Jun 17, 2015 at 17:03
  • I have an intel i7 8mb machine and never had any issues. I had Nvidia issues before, for config reasons but these were solved long ago. I tried using a previous kernel without success, so it isn't the video driver either probably.
    – tihe
    Jun 17, 2015 at 20:00

5 Answers 5


I had a similar error and the problem was due to my /tmp/ directory having the incorrect permissions and .Xauthority. This Answer worked for me (I copied and pasted it in case it gets removed, @SiddharthaRT is the original author):

Press Ctrl+Alt+F3 and login into the shell.

Now run ls -lah. If in the output the line

-rw-------  1 root root   53 Nov 29 10:19 .Xauthority

then you need to do chown username:username .Xauthority and try logging in.

Else, do ls -ld /tmp. Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt.

drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Else, you need to do sudo chmod a+wt /tmp and check again.

If not both, I'd recommend you either

dpkg-reconfigure lightdm

or uninstall, reinstall it.

Now press Alt+-> until you reach the login screen again, and restart.

  • chown .Xauthority worked. How could those permissions have changed? Or is it originally root:root and is chown a workaround? I am trying to understand what the cause of my issue was. I did not make any changes apart from (automatic) updates.
    – tihe
    Jun 17, 2015 at 20:17
  • So I'm not claiming to know exactly what happened, when this happened to me I was messing around with installing gnome shell since I didn't like unity. .Xauthority was also the only fix I ended up needing to make. I'm guessing that the owner of the file changed with an update and when you try to log in, your user can't modify that file. Can you check to see what packages were updated?
    – Doryx
    Jun 17, 2015 at 21:35
  • But if that would be caused by an update I would expect to see the entire Ubuntu community complaining. I am not that well versed in dpkg. How do you check the packages that have been updated?
    – tihe
    Jun 17, 2015 at 22:02
  • 1
    Per this answer it looks like it is in the Ubuntu Software Center. Do you have any PPAs that you added?
    – Doryx
    Jun 17, 2015 at 22:18
  • No PPA, but I see some updates of unity (though unity does not seem to be the culprit) and Xorg/ Xserver. I think it is a big drawback of Ubuntu (or linux) that you can lose so much time with a simple upgrade.
    – tihe
    Jun 18, 2015 at 19:16

This is just a workaround that save me in two cases I've faced:

  • One was a bad update of gnome-session from a PPA.
  • Another one, I couldn't figure out but all trials left me in front of lightdm.

In both cases, I got login loop with lightdm then:

  1. I switched to another display manager gdm:

    sudo apt-get install gdm
  2. Reboot, login was successful.


I had almost the same problem.

  1. When the logon screen will be shown press Ctrl+Alt+F1.

This will take you to TTY1.

  • Login with your default credentials.
  • Type in TTY1: sudo -s
  • Then type: adduser username(Type whatever you want instead of username)
  • Choose password and confirm it.
  • Then go to GUI by pressing Ctrl+Alt+F7
  • Login with your new user.
  • Go to System Settings>User Accounts>Your new user.
  • Click on Unblock and type your old user's password.
  • Change Account type to Administrator.
  • Click on your old user, select it and then click - on the bottom of the "My Account"'s list.

    I do this when I accidentally change my preferences of my Graphics Card

If you have problems with unity, Go to TTY, login as root and type:

unity --reset

I have personally verified that this does work. However, if your objective is only to be able to run Unity, then there does not appear to be any specific need to delete the old user, which is what you will be doing if you follow the instructions in the foregoing answer. All I needed to do was to logout, choose the new user, and choose Unity from the gdm login screen. If you don't delete the old user, you might also choose not to make the new user an administrator.


What you are describing looks like what I recently faced for Ubuntu 15.04. Press Ctrl+Alt+F1, login with your user and password and Try this:

sudo apt-get install linux-generic

Then go back to your lightdm by pressing Ctrl+Alt+F7. If it is not fixed, try rebooting. Let me know if it works for you.


What I did

  1. Enter into recovery mode
  2. Select build broken packages(or something like that)
  3. Select yes
  4. Click enter

It worked for me!!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .