1

rfkill list all

0: asus_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: asus_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: bluetooth
    Soft blocked: no
    Hard blocked: no

When I hit the hardware button (Fn+F2) the values toggle so the two wlans change

from:  no yes; no no  
  to: yes no; yes no

Even the "rfkill unblock all" or unblock wlan or unblock do the same kind of toggling, and can not get them all to ' no no ; no no '.

Bluetooth works fine, by the toggles (hardware button / choosing system tray / command line rfkill).

 # uname -r
 3.16.0-30-generic
 # sudo dmidecode | grep 'System Information' -A2
System Information
    Manufacturer: ASUSTeK Computer Inc.
    Product Name: U32U

I managed to get the no, no; no no (phy0; asus_wlan, soft & hard). [no yes; no no : Fn+F2 -> yes no; yes no : rfkill unblock wlan -> no, no; no, no]. Not sure if sudo modprobe asus_nb_wmi wapf=4 did something.

However, now despite having all four 'no' its still showing 'wifi disabled by hardware switch', and greyed out. Does it have a refresh time when that takes effect ?

I have seen the post "Wireless disabled by hardware switch on an Asus X550V" but that does not provide solution to my problem.

5
  • What is your ASUS model? And please add output of uname -r to your question.
    – Pilot6
    Jun 9, 2015 at 19:13
  • Please edit your question and add output of sudo dmidecode | grep 'System Information' -A2 terminal command.
    – Pilot6
    Jun 9, 2015 at 19:18
  • On my dell laptop, I also have 2 devices listed by rfkill for my wifi: phy0 and brcmwl-0. Although only one for bluetooth, hci0
    – solsTiCe
    Jun 9, 2015 at 19:21
  • 1
    possible duplicate of Wireless disabled by hardware switch on an Asus X550V
    – chili555
    Jun 9, 2015 at 19:25
  • On my Acer laptop, the Bluetooth is listed 2 times acer-bluetooth and hci0. I'm having some issues with the Bluetooth connectivity and I wonder what cause it. Do you think having those two entries in the list might cause it? Is there a way to blacklist one of them and check if it works? Thanks!
    – DariusP
    Mar 6, 2021 at 20:27

1 Answer 1

0

That is because wireless is also controlled also by asus_nb_wmi module.

You can probably fix this wrong behavior by running

sudo modprobe asus_nb_wmi wapf=4

If it helps, I will add how to make it permanent.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .