0

I'm trying to get SPSS 22 working under Xubuntu 15.04; it's the only piece of software I'm missing to make my migration to Linux complete.

Before you all start suggesting PSPP/R; my boss requires me to work in SPSS, because she knows and understand it, so unfortunately other software is not an option. Also, PSPP does not support many of the stats I have to do (like repeated measures ANOVA).

Alright, so I installed the software without problems up to the point where you licence it at the end, at which point I get an error about an internal problem with Ubuntu, which I sent off at the time but unfortunately I did not save (silly me!). However, it seems all the files are installed correctly. I am then supposed to start spss using the stats file in the /bin folder. If I try that, this happens;

narameh@Hydrogen:/opt/IBM/SPSS/Statistics/22/bin$ ./stats
*** Error in `/opt/IBM/SPSS/Statistics/22/bin/STATISTICS': free(): invalid next size (fast): 0x00007f37880050d0 ***
*** Error in `/opt/IBM/SPSS/Statistics/22/bin/STATISTICS': malloc(): memory corruption: 0x00007f3788005150 ***
Aborted (core dumped)

I searched around a bit online and installed;

lib32z1
lib32ncurses5
libstdc++5

as this seemed to have solved similar problems for others.

I also tried gksudo, but this still throws the first error, not the second;

narameh@Hydrogen:/opt/IBM/SPSS/Statistics/22/bin$ gksudo ./stats
GNOME_SUDO_PASS
*** Error in `/opt/IBM/SPSS/Statistics/22/bin/STATISTICS': free(): invalid next size (fast): 0x00007f0a6400a130 ***

I then took a look at the contents of the stats file;

#!/bin/sh
SPSS_HOME=/opt/IBM/SPSS/Statistics/22
cd /opt/IBM/SPSS/Statistics/22
. /opt/IBM/SPSS/Statistics/22/bin/statsenv.sh
exec /opt/IBM/SPSS/Statistics/22/bin/STATISTICS "$@"

As #!/bin/sh is not quite #!/bin/bash I tried creating a file called spss.sh, made it executable and put in the same code with #!/bin/bash instead. No dice.

Anyone has any more input on how to make this baby work? Rebooting in windows takes ages every time I try it. I am a relatively new Linux user, so please be so kind as to keep that in mind if/when you answer :).

0

Using Ubuntu 15.04 and SPSS 22, I followed the same steps you did, up to creating a new #!/bin/bash script. I got the same errors.

However, I was able to install and run SPSS 23 with no problems. I didn't use gksudo, but I still had these 3 packages installed: lib32z1 lib32ncurses5 libstdc++5

0

The official IBM Fix Pack FP002 for SPSS22 on Linux x64 fixes this issue. It can be found here (requires registration).

In my case, on Ubuntu 15.10, this makes stats executable without errors. Ubfortunately, SPSS still won't start...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.